Awful experience with Google Kubernetes

Hi

I recently tried to install Neo4j on the google kubernetes engine

Almost at the end I got these two errors in the google cloud UI on the cluster line

  • Can’t scale down a node because there’s no place to move its Pods
  • Pod is blocking scale down because it’s a non-daemonset, non-mirrored, non-pdb-assigned kube-system pod

helm install my-neo4j-release neo4j/neo4j-standalone -f my-neo4j.values.yaml worked

But kubectl rollout status --watch --timeout=10000s statefulset/my-neo4j-release

still waiting for 1 pods to be ready....and it's still waiting.

Hi @tard.gabriel
I suspect the GCP instance where you are trying to install the helm-chart might not have enough resources to handle the successful deployment of Neo4j.
Can you please let me know what machine type are you using?

Thank you for your quick response

I didn't figure out yet how to fix it, but their logs is saying that I couldn't mount the disk on my cluster because they were not from the same region or zone.