WARNING: Max 1024 open files allowed, minimum of 40000 recommended. See the Neo4j manual


(Paolodipietro58) #1

I got the error in object when I bin/neo4j start.

neo4j@neo4j:/neo4j/neo4j-community-3.5.0$ bin/neo4j start
Active database: graph.db
Directories in use:
  home:         /neo4j/neo4j-community-3.5.0
  config:       /neo4j/neo4j-community-3.5.0/conf
  logs:         /neo4j/neo4j-community-3.5.0/logs
  plugins:      /neo4j/neo4j-community-3.5.0/plugins
  import:       /neo4j/neo4j-community-3.5.0/import
  data:         /neo4j/neo4j-community-3.5.0/data
  certificates: /neo4j/neo4j-community-3.5.0/certificates
  run:          /neo4j/neo4j-community-3.5.0/run
Starting Neo4j.
WARNING: Max 1024 open files allowed, minimum of 40000 recommended. See the Neo4j manual.
Started neo4j (pid 17466). It is available at http://0.0.0.0:7474/
There may be a short delay until the server is ready.
See /neo4j/neo4j-community-3.5.0/logs/neo4j.log for current status.

I added the following lines in /etc/security/limits.conf

neo4j soft nofile 40000
neo4j hard nofile 40000
root soft nofile 40000
root hard nofile 40000

but the error persists. I also tried an alternate way, adding NEO4J_ULIMIT_NOFILE=60000 to /etc/default/neo4j with no success.

Please, note that the error is only on the console output but NOT into the neo4j.log!
Maybe it's not an error anymore?

Can anyone provide a good answer for v3.5.0?

My config is:

  • Ubuntu server 18.04.01
  • Neo 3.5.0 Community, Browser 3.2.13

(Stefan Armbruster) #2

In Ubuntu you put your settings in /etc/security/limits.d/neo4j.conf instead.


(Paolodipietro58) #3

No Stefan. I used your suggestion but the error persists.


(Stefan Armbruster) #4

Try with these file contents:

* soft nofile 40000
* hard nofile 40000

And be sure to reboot the machine afterwards. I'm not aware of a way to apply this config change otherwise.


(Paolodipietro58) #5

Hi Stefan,

Sorry but neither this approach runs.

Is there a way to check the effective value into the running OS after neo4j is started?

This is because The message is not present into the log,and in this moment, all the different alternatives are loaded together!!!!

I’m available to test everything necessary to solve the problem, but I need inputs :slightly_smiling_face::slightly_smiling_face::slightly_smiling_face:


(Stefan Armbruster) #6

check what ulimit -n spits out. Try with root user and the uid used for running neo4j - most likely there's a neo4j user for this.