unionFind doesn't work!


(Mehdi Ajroud) #1

Hey everyone ,

I was working on neo4j in Windows and now I moved to Ubuntu since it's faster and much better in term of supporting huge data .
What I am doing right now is rerunning all my queries and it ended up by displaying an error when I ran this query :

CALL algo.unionFind('Attributaires', 'CollaborateWith', {write:true, partitionProperty:"clusterId",weightProperty:'weight', defaultValue:0.0, threshold:2.0, concurrency: 1})
YIELD nodes, setCount, loadMillis, computeMillis, writeMillis;

and when I tried to find it by using CALL apoc.help("union") , it doesn't show up !

NB : I am using Neo4j (version 3.4.10 , Edition : Community ) APOC : apoc-3.4.0.3


(Stefan Armbruster) #2

algo.unionFInd is not part of APOC. Instead it's part of https://github.com/neo4j-contrib/neo4j-graph-algorithms. Install the graph algorithm package and try again. If it still fails provide the error message you're seeing.


(Mehdi Ajroud) #3

Thank you Stefan :slight_smile: It works now