Unable to change password on new cluster setup

I'm setting up a cluster on AWS using the latest 4.0.3 AMI.

The cluster is spread between different availability zones, but in the same VPC and in the same security group. The security group port 5000,6000,7000,7687,7474,7473 is opened internally in the sg.

Everything looks good when checking the status:

{
  "lastAppliedRaftIndex": -1,
  "votingMembers": [
    "055b9e06-107a-40fe-b9d3-0009361dcf73",
    "09f92f25-7c2d-4257-84b0-8a0eeca8dc34",
    "678445e7-ec2f-4503-8172-4aa1f69c906e"
  ],
  "memberId": "678445e7-ec2f-4503-8172-4aa1f69c906e",
  "leader": "678445e7-ec2f-4503-8172-4aa1f69c906e",
  "millisSinceLastLeaderMessage": 0,
  "raftCommandsPerSecond": 0.0,
  "healthy": true,
  "core": true,
  "participatingInRaftGroup": true
}

I can login using the default neo4j/neo4j password on the leader. But then when asked to change the default pwd, everything just stops and nothing happens when enetering a new. The browser just says: Please wait...

The log just give me a certificate error due to incorrect SSL certificate for https traffic on server and some replication and prune lines.

Any suggestions what could be wrong?

For security reasons, when you launch a cluster you must either specify a password or one is generated for you in the CloudFormation output. When your CF stack finishes deploying, you must use this password and neo4j/neo4j doesn't apply.

It must be this way - because by policy Amazon doesn't allow listing/publishing things that deploy with the default username/password because such systems are too easy to infiltrate from the outside.

If you're using the Marketplace deploy method, consult the cloudformation stack outputs for your password.

Thank you David. Will look into CF output!

No CF stack visible. Will do a new reinstall with Casual Cluster AMI from Marketplace. I installed them separate in current setup.

I believe it's in our documentation as well that if you're launching a bare AMI -- the password is set to the AMI ID