"test and save connection" does not respond with success or error message


(Alcampopiano) #1

Hi all,

I am trying to use ETL to import from my organisation's relational database (MS SQL Server). I think I'm doing something incorrectly with the JDBC driver.

When I click "test and save connection" nothing happens. That is, I get no red or blue error/success banner at the top.

Does this general setup look correct to you?

Neo4j 3.5.2
ETL 1.3.3

Any help is very much appreciated.

Sincerely,
Allan


(Ameyasoft) #2

I used jdbc driver version 6.2 (name: mssql-jdbc-6.2.2.jre8.jar) from Microsift site. I am using MS SQL 2014.

After downloading I copied the .jar file to plugins folder and ran this script:
call apoc.load.driver("com.microsoft.sqlserver.jdbc.SQLServerDriver")

This worked for me.


(Michael Hunger) #3

The ETL tool is unrelated to APOC.

Did you use the same JDBC drivder jar for the JDBC-driver path? B/c your screenshot says sqljdbc42.jar


(Alcampopiano) #4

@michael.hunger This is possible. Is there a specific path the driver has to be on?

I just downloaded the driver and put it into /usr/share/java and then selected that jar file in the ETL GUI.

I'm new to this tool so any help is greatly appreciated.


(Michael Hunger) #5

The ETL UI should make the file path available to the backend, so make sure it's somewhere where it can be read by your user.


(Alcampopiano) #6

@michael.hunger I put the JDBC driver in my home folder so that I know I have permissions to read it. Unfortunately, I still get no red or blue banner when I click "test and save connection". Nothing seems to happen.

My driver path is:
home/sqljdbc_6.0/enu/jre8/sqljdbc42.jar

Also, it seems that I cannot get the ETL UI to give me an error message, regardless of the options I choose. Perhaps this is not related to the driver.


(Michael Hunger) #7

Can you check in the Javascript logs?

If you enable developer mode in Neo4j Desktop Settings
You will have an application deverloper tools button when you reload the ETL app.


(Ameyasoft) #8

Your screenshot shows no port number. It should show 1433 as the port number. Also connection URL should read like this:
jdbc:sqlserver://localhost:1433;databaseName=abcd

Here is my screenshot:
alcam


(Alcampopiano) #9

@michael.hunger Okay, good idea. Here is the JS error that appears when I click "test and save connection":

The ETL UI (now updated to 1.3.5) shows this pop up:

sc1

I get all the same behaviour regardless of what I enter into the ETL UI fields.

Any guidance is appreciated.

@ameyasoft I forgot to add the port to that example, but normally, yes, it is specified. The issue actually occurs regardless of what is typed into the fields. Updated the screenshot.


(Michael Hunger) #10

Please enable the background process for the app. I messed up teh JS packaging so the image didn't get added correctly.


(Ameyasoft) #11

Please send me the link from which you downloaded the JDBC driver, SQL server version and your OS.


(Alcampopiano) #12

@michael.hunger Thank you so much. This works perfectly.

Al