Support for Point() type in cypher-shell

We are using Neo4j Enterprise 3.5.9 and have a node with the following properties:

<id>:28, center: point({srid:4326, x:114.159662, y:22.282054}), created: 1514764800.0, lat: 22.282054, lng: 114.159662, name: Centralradius_m: 500

When I run the simple cypher query in the desktop or browser I get a return.

`match (t:Thing) return t limit 1;`

When I run it in the cypher-shell I get:

Point is not supported as a return type in Bolt protocol version 1. Please make sure driver supports at least protocol version 2. Driver upgrade is most likely required.

So my question is if my application connects using bolt, will this work? and if not how and what do I need to upgrade to get it to work?

Also, can I create an Index on the attribute :center, or should I create a composite index on {srid:4326, x:114.159662, y:22.282054}?

Please upgrade to the latest neo4j or cypher-shell.
3.5.9 was packaged with a wrong version (old) of cypher-shell.

Thanks @michael.hunger