Something happened to the labels

(David Makovoz) #1

Something went wrong with my neo4j community 3.3.0 database.
When I run in the browser
match (n) return n limit 1
The query doesn’t return, just keeps spinning in the browser, and I get the following error (in the linux terminal running neo4j )
ERROR Client triggered an unexpected error [LabelAccessFailed]: Label retrieved through kernel API should exist.

When I run this command in the shell
match (n) return n limit 1
I get back something:
| Node[335339]{property1:0,property2:0}

but running schema throws
RuntimeException: org.neo4j.kernel.api.exceptions.LabelNotFoundKernelException: Label by id 8'
and running match (n) return labels(n) limit 1
throws QueryExecutionException: Label by id 1

I tried to google "LabelAccessFailed" and "LabelNotFoundKernelException" but didn't see anything relevant.

Any help, suggestions are appreciated.

David

0 Likes

(Andrew Bowman) #2

You should upgrade at least. .0 releases tend to be the most buggy, you should at least be on the latest patch version for the minor version of interest. Here's the [3.3.x changelog], though you should know we're up to 3.5.x by now.

0 Likes