Some APOC procedures not available

I have loaded the APOC 4.2.0.0 on my project DBMS. I can and have used the apoc.load.json( ) procedure. But some of the others aren't there. I get the following error using "call apoc.help("load"): There is no procedure with the name apoc.help registered for this database instance. Please ensure you've spelled the procedure name correctly and that the procedure is properly deployed.

I am following this video: Load JSON - APOC Documentation

Also, what is the project files area used for under my DBMS on Desktop?

Thank you.

Hi @g.j.westfall

It works fine in my environment.
I haven't checked the details, but it may be the version.

Neo4j 4.2.4
APOC 4.2.0.2
Neo4j Desktop 1.4.3
macOS Big Sur

Not for me. When I start to type in CALL apoc. it shows me 28 procedures, that is all. And mine only shows 4.2.0.0. It doesn't show an update in the desktop.

I just reloaded the plugin v4.2.0.0, same results, only 28 procedures no apoc.help.

I reloaded the Neo4j Desktop, still no joy.

Hi @g.j.westfall

To update from 4.2.0.0 to 4.2.0.2, uninstall and install the APOC Plugin in the Neo4j Desktop.

Tried that. When I uninstall APOC 4.2.0.0 plugin, I shut everything down, and restart; then the only version available in the plugins is 4.2.0.0. I thought it might be because I had it set to offline database. I unchecked that and then checked for updates, but it still only shows 4.2.0.0.

Let me try to copy the 4.2.0.2 jar file to the plugins directory and see what happens. And thank you for taking the time, I do appreciate it.

Fingers crossed it works.

Actually, I think it's the neo4j.conf file. I have the following line:

Example allow listing

dbms.security.procedures.allowlist=apoc.coll.,apoc.load.

This seems to be the restriction. Can you please look in your neo4j.conf file at these 2 sedttings:

A comma separated list of procedures and user defined functions that are allowed

full access to the database through unsupported/insecure internal APIs.

dbms.security.procedures.unrestricted=jwt.security.,gds.,algo.*

A comma separated list of procedures to be loaded by default.

Leaving this unconfigured will load all procedures found.

dbms.security.procedures.allowlist=apoc.coll.,apoc.load.,gds.*

Thank you for any help.

1 Like

I ended up deleting the project, creating a new one (4.2.4), reload APOC and everything is good. Still don't know how I got so turned around, but kay sera, sera.