Not able to change websocket URL with DNS name of aws EC2

AWS Setup :

  • Ec2 instance provisioned with private IP (No Pubic IP/DNS). Installed Neo4j 1.4.3 version, successfully able to start the server.
  • To make it accessible over the internet, placed an load balancer infront of ec2.
  • Now, when i try to access neo4j browser with (http::7474/) i could able to access, able to connect to graph db via bolt.


  • But, when i tried with Load balancer DNS name, i could able to see neo4j browser coming up, but then the websocket connection get fails(wss::7687).
  • Is there any option to map websocket url with dns name instead private-ip.

Feedback from a colleague

He doesn't put much data there, so few thoughts:

  • if he wants a load balancer only for Neo4j, I'd rather use network load balancer which has full support for TCP packets (it's layer 4 vs regular load balancer which is layer 7)
  • but his set up should work, it works for us although that's hacky. I wonder if he did install SSL certificate correctly on the load balancer
  • it'd be great to get the error message that comes up with the fail. That'd tell us where the problem may lie