Nginx HTTPS proxy a docker Neo4j

Good Day Team,

I'm trying to setup a proxy to our Neo4j which is running thru Docker via nginx on a Google Cloud CentOS 6 instance.

Upon configuring the .conf file of nginx, we were able to redirect the web portal of our Neo4j in HTTPS.

However when logging in, we get this error:

WebSocket connection failure. Due to security constraints in your web browser, the reason for the failure is not available to this Neo4j Driver. Please use your browsers development console to determine the root cause of the failure. Common reasons include the database being unavailable, using the wrong connection URL or temporary network problems. If you have enabled encryption, ensure your browser is configured to trust the certificate Neo4j is configured to use. WebSocket readyState is: 3

We have already added the ports 7474, 7473 and 7687 to our Firewall rules, but still no luck.

I'm hoping for your immediate assistance on this. Many thanks in advance.

Best regards,


Hi Raffy,

Just wondering if the issue has been addressed? I am getting the similar issue and the neo4j browser is forced to use wss:// or bolts:// connection which doesn't work and showing the same error as your mentioned above. Not sure if there is any way can be done in nginx proxy end.