Neosemantics (n10s) Graph App Problems with Install

The Neosemantics (n10s) Graph App does not install for me using the Install button from the Neo4j Developer Graph Apps Gallery or by manually copy and pasting the install link into Neo4J Desktop's Graph App URL install box next to the Install button. I'm getting an error message saying "An error occurred while processing Graph Application Neosemantics. See the logs for details." But I can't find the log information. Also, the repository link for the Neosemantics (n10s) Graph App in the Graph App Gallery does not work: https://github.com/neo4j-apps/n10s.

Hey @olijnyknicholas, I have just tried it here and everything seems fine. What version of Neo4j Desktop are you using?

You can find the logs by going to the Developer menu and then Developer Tools. It should open the console window. You should be able to filter for GRAPH_APP_INSTALL_FAILED and then click on error to reveal the message.

That is a good point about the repository, it is currently private so I will make it public.

Thanks for the prompt reply.

I'm using Neo4J Desktop Version 1.2.4

I found the log error:

Capture

Not sure what "No suitable version found" means.

OK, this means that there is no version of the neosemantics app that supports version 1.2.4, I think we released it for Desktop 1.2.6. If you open up the Notification Centre pane in Desktop (bell icon) and click the two arrows it should update to the latest version.

I performed the update as you suggested and it works now. Looking forward to exploring the app. Thank you for your help.

Great news! Let me know if you have any feedback on the app.