Neo4j slave node doesn't sync data from master node in HA cluster

Hi everyone,

I need some help here.

I'm trying to put a new node into my existing HA cluster and sync the data from the master node (there is no data on my new node).
The ip of my new node is

I set following configuration:
ha.initial_hosts=,,,,, (copied from one node in cluster)
ha.server_id=200 (a new one)

Other configuration is the same with the configuration of nodes in cluster.

After I start the new server, I can see following in the log:

2020-10-22 03:13:49.645+0000 INFO  ======== Neo4j 3.2.3 ========
2020-10-22 03:13:49.669+0000 INFO  Starting...
2020-10-22 03:13:50.469+0000 INFO  Write transactions to database disabled
2020-10-22 03:13:50.559+0000 WARN  Causal Clustering metrics was enabled but the graph database is not in Causal Clustering mode.
2020-10-22 03:13:50.851+0000 INFO  Bolt enabled on
2020-10-22 03:13:50.874+0000 INFO  Initiating metrics...
2020-10-22 03:13:52.032+0000 INFO  Attempting to join cluster of [,,,,,]
2020-10-22 03:13:52.138+0000 INFO  Joined cluster: Name:neo4j.ha Nodes:{97=cluster://, 98=cluster://, 99=cluster://, 5=cluster://, 102=cluster://, 103=cluster://, 200=cluster://, 106=cluster://, 107=cluster://, 108=cluster://} Roles:{coordinator=97}
2020-10-22 03:13:52.140+0000 INFO  Sending metrics to Graphite server at
2020-10-22 03:13:52.144+0000 INFO  Instance 200 (this server)  entered the cluster
2020-10-22 03:14:19.281+0000 INFO  Instance 108  has failed
2020-10-22 03:14:19.282+0000 INFO  Instance 5  has failed
2020-10-22 03:17:52.339+0000 INFO  Started.
2020-10-22 03:17:53.060+0000 INFO  Mounted REST API at: /db/manage
2020-10-22 03:17:53.137+0000 INFO  Server thread metrics has been registered successfully
2020-10-22 03:17:53.832+0000 INFO  Remote interface available at http://localhost:20027/

It seems this node has successfully joined the cluster, but it never get data from the existing cluster. I also tried to add the ip of this node in the list of ha.initial_host, still doesn't work.

I'm using the enterprise version 3.2.3.

Can someone help me figure this out?