Neo4j ETL Tool 1.4.2 cannot locate neo4j-import.bat

Using Neo4j Desktop 4.0.1
Using Neo4j ETL 1.4.2

SQL Server 2019 and JDBC 7.2.2.jre8.jar

ETL able to test and connect to SQL Server
Able to complete Mapping
Able to Save Mapping and go to Import process

The follow information error occurs when trying to import. Searched for the file but cannot find the file - appears it was not created.

Import your data into Neo4j

Press the button and start import your data


Connection name:

From database: KMERSQL

Of type: MSSQL


Bulk Import


Instance name: SEQUENCE

Version: 4.0.1 - enterprise (LOCAL)


COMMAND: java -cp "D:\NEO4JDB\graphApps_global\neo4j-etl-ui/dist/neo4j-etl.jar;C:\Program Files\Microsoft JDBC Driver 7.2 for SQL Server\sqljdbc_7.2\enu\mssql-jdbc-7.2.2.jre8.jar" org.neo4j.etl.NeoIntegrationCli export --mapping-file "C:\Users\weberp6\AppData\Local\Temp/mssql_KMERSQL_mapping.json" --destination "D:\NEO4JDB\neo4jDatabases\database-ca3845ba-c9f3-427a-8510-c59ff87ee58f\installation-4.0.1/data/databases/graph.db/" --import-tool "D:\NEO4JDB\neo4jDatabases\database-ca3845ba-c9f3-427a-8510-c59ff87ee58f\installation-4.0.1/bin" --rdbms:password "2020Shadow02291996!" --rdbms:user "sa" --rdbms:url "jdbc:sqlserver://localhost:1433;databaseName=KMERSQL" --csv-directory "C:\Users\weberp6\AppData\Local\Temp" --options-file "C:\Users\weberp6\AppData\Local\Temp/import-tool-options.json" --using "bulk:neo4j-import" --neo4j:url "bolt://localhost:7687" --neo4j:user "neo4j" --neo4j:password "12345" --force - Command failed due to error (IllegalArgumentException: Unable to find import tool: D:\NEO4JDB\neo4jDatabases\database-ca3845ba-c9f3-427a-8510-c59ff87ee58f\installation-4.0.1\bin\neo4j-import.bat). Rerun with --debug flag for detailed diagnostic information.

I ran into the same error when attempting to use a graph at version 4.0.3.

I think the issue is the neo4j-import.bat file listed in the error doesn't get created in the \.Neo4jDesktop\neo4jDatabases\database\installation-4.0.3\bin directory.

The bat file seems to get created at version 3.5.14. I can see it in \.Neo4jDesktop\neo4jDatabases\database\installation-3.5.14\bin on my server when I create a new graph.

For now, I'm using this older version. It might be possible to copy the bat file to the the new version's directory or externally download the file.

I think Neo4j needs to look into automatically including this file in later versions so users don't have this problem.