Neo4j ETL & Snowflake

Any suggestions on getting NEO4J ETl to read snowflake tables?

COMMAND: java -cp "C:\Users\xxx.Neo4jDesktop\graphApps_global\neo4j-etl-ui/dist/neo4j-etl.jar;C:\Users\xxxx\Downloads\snowflake-jdbc-3.8.5.jar" org.neo4j.etl.NeoIntegrationCli generate-metadata-mapping --rdbms:url "jdbc:snowflake://" --rdbms:password "xxxxx" --rdbms:user "neo4j" --schema "xxxxx" --output-mapping-file "C:\xxxxx.Neo4jDesktop\neo4jDatabases\database-044ce08b-9ec3-4542-8575-f9fd9a69b25a\installation-3.5.6/import/jdbc_xxx_LXPRDUSRF_mapping.json"

  • Skipping reading import options from file because file doesn't exist.

  • Creating RDBMS to CSV mappings...
    Available schema: INFORMATION_SCHEMA
    Available schema: xxxxx
    Available schema: INFORMATION_SCHEMA
    Available schema: PUBLIC
    Available schema: TPCDS_SF100TCL
    Available schema: TPCDS_SF10TCL
    Available schema: TPCH_SF001
    Available schema: TPCH_SF1
    Available schema: TPCH_SF10
    Available schema: TPCH_SF100
    Available schema: TPCH_SF1000
    Available schema: TPCH_SF10000
    Available schema: WEATHER

  • Using database plugin for

  • Crawling schemas

  • Retrieving all schemas

  • Retrieving all catalogs

  • Could not log SQL warnings for result set
    net.snowflake.client.jdbc.SnowflakeSQLException: Result set has been closed.
    at net.snowflake.client.jdbc.SnowflakeBaseResultSet.raiseSQLExceptionIfResultSetIsClosed(
    at net.snowflake.client.jdbc.SnowflakeBaseResultSet.getWarnings(
    at sf.util.DatabaseUtility.logSQLWarnings(
    at schemacrawler.crawl.SchemaRetriever.retrieveAllSchemas(
    at schemacrawler.crawl.SchemaRetriever.retrieveSchemas(
    at schemacrawler.crawl.SchemaCrawler.lambda$crawlSchemas$11(
    at sf.util.StopWatch.time(
    at schemacrawler.crawl.SchemaCrawler.crawlSchemas(
    at schemacrawler.crawl.SchemaCrawler.crawl(
    at schemacrawler.utility.SchemaCrawlerUtility.getCatalog(
    at org.neo4j.etl.sql.DatabaseClient.getCatalog(
    at org.neo4j.etl.sql.DatabaseCatalog.(
    at org.neo4j.etl.sql.metadata.TableInfoAssembler.(
    at org.neo4j.etl.commands.DatabaseInspector.buildSchemaExport(
    at org.neo4j.etl.NeoIntegrationCli.main(

  • Processed 13 rows for

  • Retrieved 0 schemas

  • Total time taken for - 00:00:00.397 hours
    -100.0% - 00:00:00.397 -

  • 0.0% - 00:00:00.000 -

  • Command failed due to error (SQLException: No matching schemas found). Rerun with --debug flag for detailed diagnostic information.

Any updates for this issue. I am using the ETL UI and cannot connect to snowflake using JDBC.
I tried the same command and I have the same error.

The connection now worked using jdbc, and without providing the name of the database on the URL.