Neo4j-admin import: Missing header of type START_ID, among entries [:START_ID;:END_ID;:TYPE]

I'm trying to import csv files using the neo4j-admin import according to the tutorial (https://neo4j.com/docs/operations-manual/current/tutorial/import-tool/) and it works until I import just the nodes. But when I add a table with relationships like this:

bin/neo4j-admin import  
  --nodes="import/headers-maintainers.csv,import/maintainers.csv" 
  --nodes="import/headers-organizations.csv,import/organizations.csv" 
  --nodes="import/headers-projects.csv,import/projects.csv" 
  --nodes="import/headers-buckets.csv,import/buckets.csv" 
  --nodes="import/headers-tables.csv,import/tables.csv" 
  --nodes="import/headers-configurations.csv,import/configurations.csv" 
  --relationships="import/headers-relations.csv,import/relations.csv"

It fails with Missing header of type START_ID, among entries [:START_ID;:END_ID;:TYPE] which sounds weird on itself. I tried to change the headers file to: start:START_ID;end:END_ID;:TYPE and even: START_ID;END_ID;:TYPE but it is still the same. What am I missing?

I use neo4j version 3.5.12.

have you tried

:START_ID,:END_ID,:TYPE

The magic header names need to have a colon : in front . Note that you have to add -- delimiter=";" if you're using anything else than a comma as field separator.

Oh my god, I was so focused on syntax of the header names that I haven't noticed the delimiters. :roll_eyes: The error is in the ; of course. Thank you, Stefan, for the hint.

1 Like

You're welcome. A second pair of eyes is so helpful sometimes - had that plenty of times myself.

1 Like