Multiple CALL dbms.queryJmx("org.neo4j:*") queries slowing down database


(Greg Walker) #1

My database has gone a bit slow. I checked the currently running queries, and I've got 10 of these running:

CALL dbms.queryJmx("org.neo4j:*")

I didn't call these myself, and they have been running for over 10 minutes each (which is longer than the timeout I have set).

Is there any way to stop these queries? I would kill each of these queries manually, but the database is running so slow I can't even long in to cypher-shell (Unable to establish connection in 5000ms).

Also, what's causing these queries to run?


(Andrew Bowman) #2

These are JMX calls being made from the browser for monitoring purposes.

Can you confirm your Neo4j version?

I believe we had a bug for certain slow JMX queries (being issued by the browser for monitoring) affecting some of our 3.4.x versions, and should have been fixed in 3.4.10.

Please use the latest patch release for the minor version you're running.


(Greg Walker) #3

Thanks Andrew. I am using neo4j-enterprise 3.5.1. Would upgrading to 3.5.2 fix it?

The browser is Neo4j Browser version: 3.2.15.

Also, is there anything I can do to kill the currently running queries? I've still got 10 of them running, each for 3+ hours.

At first I couldn't log in to cypher-shell because I was unable to establish a connection in under 5000ms. However, I am now able to log-in, but when I try and kill the individual queries I get the following response:

neo4j> CALL dbms.killQuery("query-6285314");
+-----------------------------------------------+
| queryId         | username    | message       |
+-----------------------------------------------+
| "query-6285314" | "me"        | "Query found" |
+-----------------------------------------------+

1 row available after 14 ms, consumed after another 0 ms

Do I have any options other than restarting Neo4j (possibly a hard-kill)?


(Greg Walker) #4

This appears to be due to a bit of a serious browser bug. Here is the explanation by Max De Marzi from the Slack channel: