Lanch neo4j

hello, i've just download neo4j i make tar and chnge to the bin directory, i run this

  • Please use Oracle(R) Java(TM) 11, OpenJDK(TM) 11 to run Neo4j.

  • Please see https://neo4j.com/docs/ for Neo4j installation instructions. and i have this error : * Please use Oracle(R) Java(TM) 11, OpenJDK(TM) 11 to run Neo4j.

  • Please see https://neo4j.com/docs/ for Neo4j installation instructions.

Can someone help me lease !!!

Hi, You will need to install Java to run Neo4j from the command line, the documentation has information about which version to use and platform specific guidance.

https://neo4j.com/docs/operations-manual/current/installation/requirements/

Alternatively if you are new to Neo4j you might consider starting with the Neo4j Desktop Application, as mentioned at the bottom of the URL above "Neo4j Desktop includes a Java Virtual Machine, JVM , for convenience. All other versions of Neo4j require Java to be pre-installed."

When installing as a apt package the correct Java is installed as part of the dependencies. See https://debian.neo4j.com/ for details.

On a server this is the preferred way of installing.
On a desktop the Neo4J Desktop environment is the easiest choice.

thks every one.. i update my java installation and it works.

1 Like