call apoc.load.jdbc("jdbc:oracle:thin:user/pass%@","....")
i am unable to make connection as this is not accepting % in the password.

is there any solution ?

try either

call apoc.load.jdbc("jdbc:oracle:thin:user/\"pass%\"@","....")


call apoc.load.jdbc("jdbc:oracle:thin:user/\\"pass%\\"@","....")

Maybe you need even a thrid \ for quoting ... or change your password ;-)

Hi @stefan.armbruster
tried in both the ways
1st case error : Neo.ClientError.Procedure.ProcedureCallFailed: Failed to invoke procedure apoc.load.jdbc: Caused by: java.net.URISyntaxException: Illegal character in opaque part at index 22:URL
2nd case error : Neo.ClientError.Statement.SyntaxError: Invalid input

thanks but can not change password.. may be this can one bug for neo4j

That's for sure not a neo4j bug - as mentioned before it's a quoting issue. Maybe you need to URL encode the %.

HI @stefan.armbruster
after ecoding % which is %25
error :Neo.ClientError.Procedure.ProcedureCallFailed: Failed to invoke procedure apoc.load.jdbc: Caused by: java.sql.SQLException: ORA-01017: invalid username/password; logon denied

lets see how we resolve this bug or this quoting issue

@michael.hunger i hope you can help with this.


Are you using the most recent apoc version?

you can pass username and password now in the config, see


CALL apoc.load.jdbc('jdbc:derby:derbyDB', 'PERSON',[],{credentials:{user:'apoc',password:'Ap0c!#Db'}})

thanks @michael.hunger earlier also i saw that but could not use for oracle database due to some syntax error.
but this time it worked.
once again thanks for support.