Installing neosemantics 4.0 (community edition)

Hi, I am trying to install the neosemantics 4.0 on the community edition 4.04. Is it possible to install it on the community edition, there instructions doesn't say any thing about that. I saw this post on Githut (issue 155). I've added
dbms.unmanaged_extension_classes=n10s.endpoint=/rdf to the neo4j.conf (/etc/neo4j) but can't find any config for n10s when running call dbms.procedures() ?

Greetings.

Hi @anykeystudio,
Yes, n10s works both in community and enterprise.
The fragment in the neo4j.conf that you mention only affects the http endpoint part of n10s but not the procedures.
If you follow the install instructions you should see the procedures. Check if there anything informative in the logs maybe?
Have you been able to install other extensions like APOC?

Cheers,

JB.

Hello @jesus.barrasa.

I swapped the community for the enterprise edition to test (Ubuntu/debian), but can't get neosemtics plugin to work there either. The enterprise edition seams to come with the neosemtics-4.0.0.jar (/usr/share/neo4j/lib). The debug.log (/var/log/neo4j) has a DiagnosticsManager reference to the neosemantics-4.0.0.0.jar when running the neo4j service.

Executing the :GET http://localhost:7474/rdf/n10s/ping in the Cypher console result in a "404 Not Found".
Setting up the default setting in GraphConfig by executing CALL n10s.graphconfig.init(); result in Neo.ClientError.Procedure.ProcedureNotFound

What step in the setup procedure am I missing?

PS. I've haven't installed APOC yet.

hi again @anykeystudio, do I read that you're copying the jar in the lib directory? That's probably the cause of the issue. It should actually go in the plugins directory instead.
Could you give this a try and let us know?

Thanks!

JB.