Install neo4j on debian jessie problem. Can't see any open port for browser

knowledge-base
(Stefan) #1

Hi I'm new here and try my first steps with neo4j. Unfortunately, the start doesn't work as expected and someone can hopefully help me.

I use Debian Jessie on my computer and installed neo4j as described here:
[https://neo4j.com/docs/operations-manual/current/installation/linux/debian/](http://INSTALLATION INSTRUCTION)

If I start it now like this:

service neo4j restart

I get the following lines displayed in syslog:

Mar 22 14:37:31 debian systemd[1]: Stopping LSB: Neo4j Graph Database server...
Mar 22 14:37:31 debian systemd[1]: Starting LSB: Neo4j Graph Database server...
Mar 22 14:37:31 debian systemd[1]: Started LSB: Neo4j Graph Database server.

sevice neo4j status

shows:

รข neo4j.service - LSB: Neo4j Graph Database server
Loaded: loaded (/etc/init.d/neo4j)
Active: active (exited) since Fri 2019-03-22 14:37:31 UTC; 8min ago
Process: 2735 ExecStop=/etc/init.d/neo4j stop (code=exited, status=0/SUCCESS)
Process: 2736 ExecStart=/etc/init.d/neo4j start (code=exited, status=0/SUCCESS)
Mar 22 14:37:31 debian systemd[1]: Starting LSB: Neo4j Graph Database server...
Mar 22 14:37:31 debian systemd[1]: Started LSB: Neo4j Graph Database server.

But with netstat -tulpn I can't detect any listening port of neo4j.

Part of my neo4j.conf:

# HTTP Connector. There can be zero or one HTTP connectors.
dbms.connector.http.enabled=true
dbms.connector.http.listen_address=0.0.0.0:7474
# HTTPS Connector. There can be zero or one HTTPS connectors.
dbms.connector.https.enabled=true
dbms.connector.https.listen_address=:7473

It's probably a rookie mistake, please help me.

Stefan

0 Likes