How to restore "copy-paste" backup to new instance?

Hello neo4j experts,
I'm a quite newbie to neo4j so my problem is definetely came from my unexperience.
I had a neo4j instance on a PC, then I had to migrate to another PC, so I backuped my data just by copying whole catalog of old existing "data path".
Снимок экрана 2021-12-22 162032

Now I know that I should had used special backup method, but I no longer have my old neo4j local inctance. I searchen the Internet and this forum, but had not find the answer about is it possible and how to restore my databases to fresh installed neo4j instance.

In my "copy-paste" backup I have neo4j DB's of versions 3.5.14, 4.0.0, 4.1.0, 4.2.0.

I'v tried to create a new project and a DB of the same version same to my old one and then replace folders from "data" folder that are:

  • ..\database-abcf6a00-a407-40e3-99bb-e7e2c041dd1d\installation-4.0.0\data\databases
  • ..\database-abcf6a00-a407-40e3-99bb-e7e2c041dd1d\installation-4.0.0\data\dbms
  • ..\database-abcf6a00-a407-40e3-99bb-e7e2c041dd1d\installation-4.0.0\data\transactions
    The result from this method was that, all of my 15 DB's of version 3.5.14 asked for password because of it's change and when I entered the pass it always says that it's wrong. For some of 4.1.0 DB's I had the same result. Some of 4.1.0 and 4.2.0 showed up and I was able to search them in Neo4j browser, but it seems that I have not all data in them. In some i have nodes but have no labels etc.

That is what I tried and it seems to be wrong fix-path for me. Is it a working solution to restore data from my "copy-paste" backup to my fresh-installed neo4j instance?

Thank you for your answers!