ETL-tool not finishing RDBMS import

Hi ,

I have recently taken neo4j enterprise free edition and was trying to import my RDBMS data into Neo4j with ETL desktop app. I could connect to database and generate mapping and save it. Last step , import data is not getting completed in app. My first thought was to check memory constraints for import. But my hardware fullfils all the conditions mentioned on website. Please let me know how should I proceed to solve this problem.

I also tried the import with command line tool , it was giving authentication token error ,in that case csv export was complete with 5572 items. Csv folder generated through neo4j-ETL desktop app has only 3576 items .

if you run the command line tool, can you get a thread-dump when it hangs?

with kill -3 <pid> or jstack <pid>

what auth-error did you get? to neo4j or the rdbms?

Hi , I got authentication token error : scheme not found on Neo4j server. I had not tried getting thread dump I will do it and get back to you. thanks

Hi, did you define a remote or a local connection in Neo4j Desktop? If you're doing an offline import to a local instance you should not have any authentication error.
If your connection is remote are you able to connect using the Neo4j Browser App in the Neo4j Desktop to run queries?


Hi , I was able to connect through Browser App.And the graph was local

Did you try to import with the offline mode? You need to shut down your neo4j instance and run the offline import mode, it's faster than the online one. This is the desired option when you start from scratch.

I had the same issue as described by tanvi.ranade. I tried initially the bulk import (offline) and it just hanged after creating the CSV's (consuming little cpu, writing nill).
When I started the graphdatabase and tried the online import, it worked out okay!?

I created this database with a password, which I had to enter at the start (before the online import). I never was asked for a password in the offline mode. Could that be the reason for this problem?

Offline mode works on the disk files directly so there is no auth.

Anything in the logs during the offline import? Was the db running or stopped?

With the first attempt the db was not running (otherwise the ETL-tool wouldn't allow the offline bulk import). When this failed, I started the db (entered my password) and used the ETL-tool to do the import online. This was successful.
I'm afraid I don't have the logs anymore available from back then.