Can't get Desktop to install/launch properly (new to Neo4j)

I previously installed Neo4j Desktop and created a project. However, I was experiencing a Java Heap error. I made an adjustment, but was still having issues. So, I tried to uninstall then reinstall Desktop. Unfortunately, now I cannot get the Desktop to launch at all. The error log is included below. It appears to be looking for a project folder in my old Desktop instance. I would like to be able to access this project, which is extensive, in my new Desktop instance. Any help would be appreciated!!! Neo4j is fantastic and I would like nothing more than to develop my application with Neo4j. Thanks in advance.

Jeff

[2020-09-14 15:31:49.150] [info] Starting Neo4j Desktop 1.3.4 @ Windows_NT 10.0.18363
[2020-09-14 15:31:49.247] [info] Starting Nest application... NestFactory true
[2020-09-14 15:31:49.254] [info] SystemModule dependencies initialized InstanceLoader true
[2020-09-14 15:31:49.269] [error] App initialization error: Error: ENOENT: no such file or directory, stat 'C:\Users\jeffn\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-16da60dc-e064-4fae-8f90-07da7d798676' {
constructor: 'Error',
errno: -4058,
code: 'ENOENT',
syscall: 'stat',
path: 'C:\Users\jeffn\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-16da60dc-e064-4fae-8f90-07da7d798676',
stack: "Error: ENOENT: no such file or directory, stat 'C:\Users\jeffn\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-16da60dc-e064-4fae-8f90-07da7d798676'"

I have recently experienced something very similar to this. Had been using Desktop quite happily when I started to get messages about 'Conflict with external services'. Searched Community and found people solved this by uninstall and reinstall which I did but then got 'Error: ENOENT: no such file or directory, ' message. I uninstalled and re-installed and now Desktop will not initialise at all.

I am on the Start-up programme so do not qualify for Enterprise support although I am using the Enterprise version under the Start-up programme agreement.

This looks like Windows permissions are preventing Neo4j Desktop from creating the necessary folders and files when creating a new DB instance.

Try redownloading, and running the installer as an Administrator: https://neo4j.com/download/

Thanks Tony but this does not resolve it. I do really appreciate you taking the time to reply though.

I've tried everything that I can think of, including your suggestion, but I still can't get Desktop to initialize. As with the other posts related to this ... everything was fine until I tried re-installing to get past a Java Heap Size error. I made adjustments and then, per instructions, attempted to re-install Desktop. And now ... nothing. I can't get Desktop to initialize.

I am also on the startup program and don't get any support from Neo4j. It's frustrating. I spent all day every day for over three weeks building my database (about 900K nodes and 1.2 million relationships). Now I can't access Neo4j and I assume the project is gone.

What do you have in that directory?
C:\Users\jeffn\AppData\Local\Neo4j\Relate\Data\dbmss\

This folder contains the three projects/databases in my original Neo4j Desktop instance ... the two Neo4j training projects (Movies and Airports). And, my start-up project is the third.

I can't access them, however ...

That's almost certainly a windows permissions issue, with faint chance of a corrupted HD.

  1. Close Neo4j
  2. Open File Explorer .
  3. Right-click the dbmss folder and select Properties .
  4. Go to Security and select Advanced .
  5. Check the box for Replace all child object permission entries with permission entries from this object at bottom.
  6. Click Apply , then OK .
  7. Start Neo4j