Apoc.export.csv.all doesn't create a file with data

I call the query:

CALL apoc.export.csv.all(

And a file isn't created.
The result is:

If I tried to save a file in another place, see the message:

Neo.ClientError.Procedure.ProcedureCallFailed: Failed to invoke procedure apoc.export.csv.all: Caused by: java.io.FileNotFoundException: /etc/1.csv (Permission denied)

The database is started through docker. How could this problem be solved?

use call apoc.export.csv.all("all.csv", {d:'\t'}) and the file will end up in /var/lib/neo4j/import.

This folder is empty. Any other approach?

do a docker exec -it <name> /bin/sh to get a shell inside the container. Now run a find / -name all.csv to see if that file is somewhere.

I' ve done in docker and without docker (install neo4j). But, a file wasn't create. What do I need to check?

Please check if your neo4j.conf contains apoc.export.file.enabled=true, additionally inspect logs/debug.log for suspicious messages.

@stefan.armbruster Thank you a lot for your help!
I added dbms.directories.import=import in conf file and it works)

1 Like