Setting apoc.import.file.enabled=true in your neo4j.conf

Did this get turned into a new topic? I couldn't find it in your topics and searching load. The suggested solution of adding file: in this thread doesn't work for me.

this does not work. I got this as error
There is no procedure with the name apoc.export.csv.data registered for this database instance. Please ensure you've spelled the procedure name correctly and that the procedure is properly deployed.

I guess you didn't install apoc correctly? Does the rest of APOC work for you?
.e.g call apoc.help("")

Hi! I would like to clarify if the following is a bug for Neo4j 4++ (4.2.1 Desktop):

After creating apoc.conf file with apoc.export.file.enabled=true line. I restarted Neo4j DB, and was able to call a simple export function
call apoc.export.csv.query('MATCH (n) RETURN (n) LIMIT 10', 'hello.csv',{})

I would like to programmatically check if this setting is enabled in my code before I make the export call. However, when I do call dbms.listConfig(), it shows that it is still set to "false".
The same happens for apoc.import.file.enabled=true.

I will do a workaround to parse the apoc.conf file for now. But my guess is this is a bug that is a result of Neo4j 3.5+ config..