Welcome to our Community!

Discuss, learn and share the power of graph thinking.

Showing results for 
Search instead for 
Did you mean: 

Community Activity

APOC - apoc.load.xml

Hello guys,  I have an issue and could need some help, because its a bit frustrating.  I wanted to use the apoc.load.xml to import some data and create also Nodes and Properties with them. I've tried this one and it worked well:  The Graph-Part shou...

code3.png nodes.png code2.png hierarchie.png

Pregel: Store Messages in Nodes

Hi everyone,I am currently trying to write a procedure using the Pregel-API, where I would like to use the compute-method, to store each of the incoming messages for a node. However, I am kind of struggling with the Messages-object right now. The pro...

N10s update multivalPropList on a non-empty graph

Hi, I am using neosemantics (n10s) to import various ontologies into my graph. One issue I have encountered is that I want some properties to be treated as lists (which is solved by setting "handleMultival": "ARRAY" in the config, then setting a "mul...

alex3 by Node Link
  • 1 replies
  • 0 kudos

Getting a subgraph from a big graph

Hi folks,I am attempting to get a subgraph and graph data(as '.txt 'or other formats) from a big graphApproach 1: Randomly sample all nodes types from the large graph   MATCH (source: Node)-[r*..]-(target: Node) WHERE source.name<>target.name WITH so...

merge multiple node with neo4j-driver in js

hello im trying to get variables of an array and create node for them so i have a foreachwords.forEach((res, index) => {to get all of the items and then run this query session.run(`MERGE (n:words{name:'${res}'})`) }but i get this error Queries cannot...

Issue when retrieving result from Neo4JRepository

Hello, I'm having an issue with deserializing a simple query using a Neo4JRepository in an example I wrote. PersonRepository has the following method signature: public interface PersonRepository extends Neo4jRepository<Person, String> { ... @Quer...

gnchark by Node
  • 7 replies
  • 0 kudos

Unable to start neo4j DB

Neo4j won't start after accidentally upgrading it from 4.2.4 to 4.4.8. Gives below error.     Caused by: org.neo4j.kernel.impl.transaction.log.entry.UnsupportedLogVersionException: Log file contains entries with prefix 4, and the highest supported pr...

Latest from our Blog