cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to set apoc.trigger.enabled in neo4j setup using helm charts

I am using neo4j-helm to run neo4j in stand alone mode and everything is working as expected. but to use triggers I need to change the $NEO4J_HOME/conf/neo4j.conf.

I tried running
helm install mygraph https://github.com/neo4j-contrib/neo4j-helm/releases/download/4.3.2-1/neo4j-4.3.2-1.tgz --set core.standalone=true --set acceptLicenseAgreement=yes --set neo4jPassword=mySecretPassword --set apoc.trigger.enabled=true -f values.yml

but it's not working.

1 REPLY 1

bradenmacdonald
Node Link

Commenting on this old thread since I couldn't find much else about this issue. I had a similar problem with the official helm chart, not neo4j-helm. The documentation explains how to enable APOC but not how to configure it, e.g. to enable triggers.

But after trying many different approaches, I finally found the solution - in the config section of values.yml, putting

config:
  dbms.config.strict_validation: "false"  # Required for APOC settings to pass validation
  apoc.trigger.enabled: "true"

successfully enabled triggers for me.