cancel
Showing results for 
Search instead for 
Did you mean: 

Installing APOC's

madhu_yada
Node Link

Hello - Sometime back I installed Neo4j 4.2.2-1 on the Linux system. Can anyone suggest to me how to install the APOC plugins (apoc.text.lpad) on Linux?

5 REPLIES 5

As I mentioned I have Neo4j 4.2.2-1 and the link you provided doesn't have that version specified for binaries. I read somewhere about the procedures that it all matters is the first two digits which is 4.2.x.x.x and the rest is negligible when choosing binaries and hence I choose the closest one 4.2.0.
When I did this, Neo4j was not able to start.
Any ideas what I'm doing wrong or supposed to look at?

@madhu.yada

correct. Choose the APOC vX.Y where X.Y is the same as Neo4j vX.Y

As to not starting look to logs/debug.log or logs/neo4j.log

madhu_yada
Node Link

Hello Dana Canzano,
Agree and hence I choose Release 4.2.0.9 · neo4j-contrib/neo4j-apoc-procedures · GitHub which is close to my version 4.2.2.1.
Any suggestions?

@madhu.yada

as per my prior update, if neo4j is not starting then there should be some detail in logs/neo4j.log or logs/debug.log to explain the failure