cancel
Showing results for 
Search instead for 
Did you mean: 

Installation error: Unable to install java: distribution does not exist. Neo4j won't be able to run until java is installed

ccano
Node

I'm having this error:

I had an older version working. But when I updated to 1.2.8 this error comes up and I don't understand it. I have java installed (with brew), several versions administrated by jenv.

Also, I'm running the community version in CLI and works well. But, I had to put the java version locally to java 11. I already tried to change the global java version (I tried with 8, 11 and 13) but the error still happening.

Thanks,

8 REPLIES 8

I have the same issue. Were you able to solve since your original post?

rlh
Node Link

Still no answer to this problem. Same issue

rlh
Node Link

I found the problem. In a previous version in the directory ../Library/Application Support/Neo4j Desktop/Application/distributions/java/ the java JVM ys version 8.21.01. and the new version need 8.42.0.21 and 11.35.13 versions.
Solutions: delete complete the /Library/Application Support/Neo4j Desktop and start the Neo4j Desktop again... "beware" if you have existing database, because they are deleted (backup them before doing this).

For some reason, it doesn't work for me. the directory "../Library/Application Support" doesn't contain "Neo4j Desktop" and the error still happening when I restart the Neo4j Desktop.

@chenquan5616 This directory may exist in your user's home directory. Try removing the directory "/Users/Your-User-Name/Library/Application Support/Neo4j Desktop". It worked for me.

Thanks @rlh, I renamed the folder and re-started the desktop and it worked !!

christian
Node Clone

Thanks @rlh I had the same problem and ...

delete complete the /Library/Application Support/Neo4j Desktop

... worked!

michael6
Node

I had an old Neo4j desktop version and are now running into the same issue, but I don't have any of these files or directories (I don't even have a ...Library/application Support/... path on my computer. I'm still using Windows 7. Does anybody have a solution?