cancel
Showing results for 
Search instead for 
Did you mean: 

Windows Neo4j Desktop Importscript with Cypher-shell not working any more in version 5

Omer
Node

Goodevening,

Iam trying to migrate - within Neo4j Desktop - from 4 to 5.

I made a new project and start te server version 5.2. Then I want to use cypher-shell i get the message 'Java' unknown. So I installed OpenJDK19 en enabled in Windows environment pointing at the OpenJDK installation directory. Then I was able to start cypher-shell. Then when I run my importscripts in cypher-shell :source \\script.cql.

Something like: "Database 'name' route not found database not accepting new transactions". The script contains create database "name" and :use "name"; So I commented the line and use the default database (Neo4j). But then there where some syntax deprecated use of the function constrain but this could be fixed. But then the scripts runs but halfway I get the error: "expected a Integer but got a -8" after some checks in the csv files I and scripts cannot find anything what could cause this error (string values).

All these above "challenges" are absent in the Project where I run 4.4.

What is the correct way for running version 5.2 in a new project within a existing Neo4j Desktop installation with a good working Project running version 4.4?

Yours Kindly

Omer

0 REPLIES 0
Nodes 2022
Nodes
NODES 2022, Neo4j Online Education Summit

All the sessions of the conference are now available online