cancel
Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Phase 2: migrate recent content

How to get started with jQA Dashboard?

ascheman
Node

Hmm, I am not quite sure if this is the right forum (there are way to many to choose from)?

However, I recently found the amazing jQA-dashboard: https://github.com/softvis-research/jqa-dashboard ... at least it looked amazing from the demo.

Nevertheless, I could hardly get it started. I wanted to work out a short demo with my customer project. When I could not get it to work, I wanted to use a pet project of mine. With both I tried several times but always failed.

I have the following issues:

  • It is not clear how to use your own database:
    • I started jqassistant:server,
    • then started the dashboard npm run dashboard (after npm run install-dashboard)
    • After some searching I found the settings page, where it suggested to use bolt://localhost and neo4j/neo4j as username/password. Since I am not using Neo regularly I was confused. From jQA I knew that http://localhost:7474 should work and that authentication is switched off by default.
    • It seems, both URLs/schemas work (http and bolt),
    • it is not necessary to use ports (e.g., http://localhost:7474),
    • but it seems to be necessary to leave username/password in place as pre-filled in the form?
  • Then: How to see any "dashboard".
    • Clicking in the navigation (e.g. http://localhost:3000/#/architecture/structure) mostly returns an error:
    • Starting the Browser inspect reveals even more errors, e.g.,
    • I guess most of it is typical for JS? But one would feel much better if there were less warnings
  • In my latest try I could at least see some content, eg. for http://localhost:3000/#/resource-management/activity, I do tried more screen shots but as new user I was only allowed to upload two?
  • My last issue currently is the off-Button in the upper right corner of severaly widgets? What is the purpose? It looks like most features are switched off by default? Switching it on shows a query: image deleted But when I press send it only prints a new stack trace to the console.
1 REPLY 1

Hi Gerd, I increased your user level.

For the app, it's best to discuss on the GH issue, but thanks a lot for your feedback.

The connection details are important for remote servers, and usually you don't want to run open databases on your machine.

The app/bolt-drivers also require connection details by default.