cancel
Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Pause, resolving how to handle anonymous content

What happened to http://localhost:7474/db/data + call apoc.export.cypher.query

Kirsten_Langend
Node Link

I am using R startGraph("http://localhost:7474/db/data/") to connect to the Neo4j DB. After the upgrade this doesn't work any more.

Previously when logging on to the localhost:7474/db/data I got this:
2X_9_93a8daab88c75f181277e610811ecb445a0a0ee4.png

What should I put instead?

On another note, I tried to use the call apoc.export.cypher.query to make a cypher export to re-create the data base in an older version. Get these types of errors:
Failed to invoke procedure apoc.export.cypher.query: Caused by: org.neo4j.internal.kernel.api.exceptions.EntityNotFoundException: Unable to load NODE with id 82.

Hope you can help?

br Kirsten

4 REPLIES 4

david_allen
Neo4j
Neo4j

What are you upgrading from and what are you upgrading to?

Hi, I upgraded my Neo4j DB from 3.x to 4.1.

alisandra_jezek
Node Link

I have been running in to the same error as documented above when attempting to use apoc.export.cypher from apoc-4.0.0.0-all-jar with Neo4j 4.0.0 as follows based on the information found at https://neo4j.com/docs/labs/apoc/current/export/cypher/:

// default config populated for illustration
CALL apoc.export.cypher.all("all.cypher", {
    format: "cypher-shell",
    useOptimizations: {type: "UNWIND_BATCH", unwindBatchSize: 20}
})
YIELD file, batches, source, format, nodes, relationships, properties, time, rows, batchSize
RETURN file, batches, source, format, nodes, relationships, properties, time, rows, batchSize;

Note that if I change the output format to JSON, it works:

CALL apoc.export.json.all("all.json",{useTypes:true})

I don't want JSON, but hey, it's a data point.

Here's what's interesting, though.

If I use the Cypher export query above on a database that WAS NOT UPGRADED from 3.5.x to 4.0.0, it creates a file with the right data in it. All of the databases I was trying originally were upgraded from 3.5.x, but when I created a dummy 4.0.0 database by hand with one node in it, the Cypher export was fine. At the risk of perpetrating a correlation-equals-causation fallacy, I wonder if they are related?

Ali

Were you able to find the cause of this? Facing a similar issue, face this error sometimes and on rerun of the apoc.export.cypher.query get the same error but with a different node. But it generally gets resolved by restarting neo4j.

Using neo4j 4.2.8 btw.