cancel
Showing results for 
Search instead for 
Did you mean: 

Upon first opening of Neo4j desktop, it gets stuck at Please choose path where you want to store application data

krwins
Node Link

Upon first opening of Neo4j desktop, it gets stuck at "Please choose path where you want to store application data" I click on Confirm but it does not do anything! HELP!

I click on Confirm but it does not do anything! I am using Windows 10. Can anyone help me because I really want to learn Neo4j!

1 ACCEPTED SOLUTION

Thanks it worked fine when i add the path to environment variable

View solution in original post

31 REPLIES 31

Can you try to type ctrl-k and enter "desktop log" that should get you to the desktop log folder.
Can you share that log file from there?

I presume you have permissions for that folder?

Hi Michael,

Thank you for responding, the only thing I can do is browse the path for that question but the confirm button doesn't do anything. I have tried multiple times re-installing Neo4j Desktop 1.2.4 but still get the same. Do I need to install Neo4j 4.0 Community Edition and if so where is it?

Thank you very much,

**Ken **

Can you try to look in:

%USERPROFILE%\.Neo4jDesktop\log.log

Yes, when I enter it at my anaconda prompt I get the attached text file.

Thank you

(Attachment Neo4j_log.txt is missing)

Your system will not allow me to attach a txt file only a picture file. That does not make sense.

It will take a very very long time to take multiple pictures of the Text file. Is there another way?

Thanks

Your system will not allow me to send a Text file, what gives? Can I send it to you another way?

Below is a copy of the return email I got.

Thanks

Neo4j Online Community neo4jcommunity@discoursemail.com

Jan 24 at 1:19 PM

Unfortunately some attachments in your email message to ["neo4jcommunity+1c19d1605fb56a5dde872a4b0104af14@discoursemail.com"] (titled Re: [Neo4j Online Community] [Neo4j Graph Platform/Desktop] Upon first opening of Neo4j desktop, it gets stuck at Please choose path where you want to store application data) were rejected.

Details:
Neo4j_log.txt: Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif).

If you believe this is an error, contact a staff member.

I changed the setting, please try again

Hi Michael,

I had deleted the Neo4j Desktop 1.2.4 again and deleted the .Neo4jDesktop file so I could re-install the program. Still got the same results. So, here is the attached .Neo4jDesktop log file!

Thank you very much for your help.

**Kenneth Reid **

Neo4j_log2.txt (5.45 KB)

Can you check if you have Powershell installed and which version?

In your log files there is an error message:

No powershell available or is incompatible

Michael

Hi Michael,

The version I have is 5.1, attached is a screen shot of the power shell:

Hi Michael,

I am sure you are busy and that is why you didn't respond to my email of the 27th Jan.

So in case you didn't receive it, here it is again.

The version I have is 5.1, attached is a screen shot of the power shell:

Thank you my friend,

**Ken **

Michael, I hope you are receiving my email because I want to learn Neo4j and I am getting frustrated. LOL

Ken

Sorry, yes very busy.

I asked in engineering and field engineering and no one had an idea what it could be.
So we're a bit out of our depths here.

Can you get started with Sandbox or Docker for the time being?

Hi Michael,

I guess I can, but don't you have a community edition for windows? My learning journey zigs and zags, lol, I stop and start and the sandbox stops after a few days. I don't want to start completely over every time I come back to it. I hope we can get this fixed. Are your techs working on this?

Thank you,

Ken

Sorry for your frustrations
I tried to explain it to them but they couldn't reproduce it.
So I'm not sure what would be the best way forward ..

Sure we do, you can download it from here:
(it's also linked from the main download page)

Hi Michael,

Can you put me in touch with your Tech dept about this issue so I can explain it to them?

Thank you, my friend,

Ken

krwins
Node Link

Hi Michael,
This problem is driving me nuts! Can you please have Tech contact me? I would appreciate it.
Ken

usalama
Node

Hi Krwins,
I am not sure if you still having this issue, but this is what I had;
I got exactly the same error msg (Confirm button does not do anything), when I tried to install New4j on Windows 10 Enterprise and the offline mode was enabled. I tried Windows 7 (offline mode disabled) and the "Confirm" button worked fine.
Good luck

Jakob97
Node

on windows 10 i also get this error...

Hello Jakob,

Is this a new install of Desktop or an upgrade?

Sometimes the confirm button is disabled because more bits are in the process of being downloaded and it will be enabled once the download completes.

Elaine

Hi I just got started learning neo4j as well and got impounded by the same problem, this is what I did to resolve it:

The issue was my user had a corrupted PATH env variable.
First, I checked if the wmic.exe was present in C:\windows\system32\wbem directory, you can check yours as well.
If true - add that path to env variable PATH. i.e -> %SystemRoot%\System32\Wbem
If not - use system-wide search to find that executable. it should be somewhere inside Windows folder.

happy learning
PS: I am on Windows 10 pro

Thanks it worked fine when i add the path to environment variable

Running into this with a fresh install on Windows 8 right now. Can you elaborate on what you mean? What exactly did you add to PATH?

In case it helps, log.log is:

[2020-08-03 22:03:20.412] [info] Starting Neo4j Desktop 1.3.3 @ Windows_NT 6.3.9600
[2020-08-03 22:03:20.597] [info] Starting Nest application... NestFactory true
[2020-08-03 22:03:20.617] [info] SystemModule dependencies initialized InstanceLoader true
[2020-08-03 22:03:20.778] [info] Initializing persistence
[2020-08-03 22:03:20.782] [info] GraphQL server is running @ http://127.0.0.1:11001
[2020-08-03 22:03:20.897] [info] Configuring crash reporting
[2020-08-03 22:03:20.902] [info] Reading settings
[2020-08-03 22:03:20.903] [info] PowerShell compatibility check
[2020-08-03 22:03:23.476] [info] PowerShell version: 5. Required version: 5.
[2020-08-03 22:03:25.238] [info] PowerShell language mode: FullLanguage
[2020-08-03 22:03:27.623] [info] PowerShell execution policy: Unrestricted
[2020-08-03 22:03:27.628] [info] Reading bundled resources C:\Users\alex\AppData\Local\Programs\Neo4j Desktop\resources
[2020-08-03 22:03:27.632] [info] Distribution folder for java should exist
[2020-08-03 22:03:31.622] [info] Will copy []
[2020-08-03 22:03:31.745] [info] Distribution folder for neo4j should exist
[2020-08-03 22:03:33.198] [info] Will copy []
[2020-08-03 22:03:33.200] [info] Reading bundled resources C:\Users\alex\AppData\Local\Programs\Neo4j Desktop\resources
[2020-08-03 22:03:33.219] [info] Distribution folder for graphApps should exist
[2020-08-03 22:03:33.227] [warn] Failed to read installed 'neo4j-bloom', will replace with bundled distribution {
  constructor: 'Error',
  stack: 'Error: Graph-App[neo4j-bloom] does not contain package.json\n' +
    '    at l (C:\\Users\\alex\\AppData\\Local\\Programs\\Neo4j Desktop\\resources\\app.asar\\dist\\main.prod.js:1:36757)\n' +
    '    at async u (C:\\Users\\alex\\AppData\\Local\\Programs\\Neo4j Desktop\\resources\\app.asar\\dist\\main.prod.js:1:104050)\n' +
    '    at async C:\\Users\\alex\\AppData\\Local\\Programs\\Neo4j Desktop\\resources\\app.asar\\dist\\main.prod.js:1:51328\n' +
    '    at async Promise.all (index 0)\n' +
    '    at async g (C:\\Users\\alex\\AppData\\Local\\Programs\\Neo4j Desktop\\resources\\app.asar\\dist\\main.prod.js:1:51200)\n' +
    '    at async C:\\Users\\alex\\AppData\\Local\\Programs\\Neo4j Desktop\\resources\\app.asar\\dist\\main.prod.js:1:52863\n' +
    '    at async t.default (C:\\Users\\alex\\AppData\\Local\\Programs\\Neo4j Desktop\\resources\\app.asar\\dist\\main.prod.js:1:53126)\n' +
    '    at async K (C:\\Users\\alex\\AppData\\Local\\Programs\\Neo4j Desktop\\resources\\app.asar\\dist\\main.prod.js:1:93589)'
}
[2020-08-03 22:03:33.233] [warn] Failed to read installed 'neo4j-browser', will replace with bundled distribution {
  constructor: 'Error',
  stack: 'Error: Graph-App[neo4j-browser] does not contain package.json\n' +
    '    at l (C:\\Users\\alex\\AppData\\Local\\Programs\\Neo4j Desktop\\resources\\app.asar\\dist\\main.prod.js:1:36757)\n' +
    '    at async u (C:\\Users\\alex\\AppData\\Local\\Programs\\Neo4j Desktop\\resources\\app.asar\\dist\\main.prod.js:1:104050)\n' +
    '    at async C:\\Users\\alex\\AppData\\Local\\Programs\\Neo4j Desktop\\resources\\app.asar\\dist\\main.prod.js:1:51328\n' +
    '    at async Promise.all (index 1)\n' +
    '    at async g (C:\\Users\\alex\\AppData\\Local\\Programs\\Neo4j Desktop\\resources\\app.asar\\dist\\main.prod.js:1:51200)\n' +
    '    at async C:\\Users\\alex\\AppData\\Local\\Programs\\Neo4j Desktop\\resources\\app.asar\\dist\\main.prod.js:1:52863\n' +
    '    at async t.default (C:\\Users\\alex\\AppData\\Local\\Programs\\Neo4j Desktop\\resources\\app.asar\\dist\\main.prod.js:1:53126)\n' +
    '    at async K (C:\\Users\\alex\\AppData\\Local\\Programs\\Neo4j Desktop\\resources\\app.asar\\dist\\main.prod.js:1:93589)'
}
[2020-08-03 22:03:33.236] [info] Will copy [ 'neo4j-bloom-1.3.2.tar.gz', 'neo4j-browser-4.1.0.tar.gz' ]
[2020-08-03 22:03:33.282] [info] Configuring proxy: NO_PROXY
[2020-08-03 22:03:33.805] [info] [1] Online check request: https://dist.neo4j.org/neo4j-desktop/win/latest.yml
[2020-08-03 22:03:34.417] [info] [1] Online check response: 200 version: 1.3.3
files
[2020-08-03 22:03:34.420] [info] Stopping any running databases
[2020-08-03 22:03:34.426] [warn] C:\Users\alex\.Neo4jDesktop\neo4jDatabases not found
[2020-08-03 22:03:34.429] [info] Registering listener for protocolManager/arguments/changed
[2020-08-03 22:03:34.472] [info] Opening main window
[2020-08-03 22:03:34.611] [error] Protocol Manager type error: url must be string. url = undefined
[2020-08-03 22:03:34.997] [info] Registering IPC listeners
[2020-08-03 22:03:35.519] [info] [1] Online check request: https://dist.neo4j.org/neo4j-desktop/win/latest.yml
[2020-08-03 22:03:36.009] [info] [1] Online check response: 200 version: 1.3.3
files
[2020-08-03 22:03:37.417] [info] Buffering metrics until application is online
[2020-08-03 22:04:15.502] [info] [1] Online check request: https://dist.neo4j.org/neo4j-desktop/win/latest.yml
[2020-08-03 22:04:16.167] [info] [1] Online check response: 200 version: 1.3.3
files
[2020-08-03 22:04:55.505] [info] [1] Online check request: https://dist.neo4j.org/neo4j-desktop/win/latest.yml
[2020-08-03 22:04:56.032] [info] [1] Online check response: 200 version: 1.3.3
files
[2020-08-03 22:05:35.506] [info] [1] Online check request: https://dist.neo4j.org/neo4j-desktop/win/latest.yml
[2020-08-03 22:05:35.843] [info] [1] Online check response: 200 version: 1.3.3
files
[2020-08-03 22:06:15.504] [info] [1] Online check request: https://dist.neo4j.org/neo4j-desktop/win/latest.yml
[2020-08-03 22:06:16.009] [info] [1] Online check response: 200 version: 1.3.3
files
[2020-08-03 22:06:55.507] [info] [1] Online check request: https://dist.neo4j.org/neo4j-desktop/win/latest.yml
[2020-08-03 22:06:56.096] [info] [1] Online check response: 200 version: 1.3.3
files
[2020-08-03 22:07:35.508] [info] [1] Online check request: https://dist.neo4j.org/neo4j-desktop/win/latest.yml
[2020-08-03 22:07:36.041] [info] [1] Online check response: 200 version: 1.3.3
files

Thanks, this helped ! Simple, but would never tried that...
Worked also on Windows 8.1

Hello @alexpghayes,

When you say this is a "fresh" install does that mean that you did not previously have Neo4j Desktop on your system?

If did remove all previous Neo4j Desktop files, it is always a good idea to restart your system to make sure there are no remaining neo4j processes running.

When you installed on Windows, did you specify that it will be used by all users? It is best to choose this option so that all permissions are available, especially when it asks you to select a folder for the application data.

You should use defaults for everything (including folder locations), but making it available to all users might help you.

Elaine

I am getting the same issue, even after adding the path in Environmental variables.
Please can anyone help me...

tonyadji
Node

Hello !

I am getting the same issue. I already tried the solution in this post but it doesn't work for me.

My log file therelog.txt (8.8 KB)

I am facing the same issue inspite of adding to the PATH variable. Frustrating start ...
after a hard days of work

If You have set env variables PATH=%SystemRoot%\System32\Wbem and it is not working,

please set path for Powershell PATH=%SystemRoot%\System32\WindowsPowerShell\v1.0

I was facing same problem and able to fix it by seting

Thanks- it worked btw. 

Hi i have  the same problem in spite of adding all the mentioned variables above as you can see in the picture blow. I would really apreaciate your help as i can't really do anything about it and i really need to fix the desktop for my project.
Thanks for your lovely help