cancel
Showing results for 
Search instead for 
Did you mean: 

Join the community at Nodes 2022, our free virtual event on November 16 - 17.

Unable to load/register the APOC library for XLXS loading

mbandor
Graph Voyager

I'm having issues loading/registering the files needed for the apoc.load.xls function. According to the online documentation, I need the following jar files loaded into the plugins directory:

  • common-collections4-4.1.jar
  • curvesapi-1.04.jar
  • poi-3.17.jar
  • poi-ooxml-3.17.jar
  • poi-ooxml-schemas-3.17.jar
  • xmlbeans-2.6.0.jar

If I add these to the plugins directory, the database does not start (throws errors). I'm using Desktop 1.4.8, and the database is 4.3.5. I've used this previously and got it to work but suddenly it doesn't work. Any ideas?

2 REPLIES 2

mbandor
Graph Voyager

Okay, looking at the debug log, it thinks the files are corrupted. Any ideas?

I found a good copy of the jar files. Things work now. Argh!