cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to install neo4j-graph-data-science-1.8.6 to Desktop 1.4.13 dbms Neoj4 4.4.3

tom_chiu
Node Link

Hi I installed Neo4j desktop 1.4.13 under Windows 10 successfully. Then I downloaded and unzipped neo4j-graph-data-science-1.8.6-standalone.zip to get the jar file. When trying to drag the jar file into the "Install" area under "Graph Apps" tab, I got the following error: "An error occurred while processing Graph Application Neo4j Graph Data Science 1.8.6. See thelogs for details (Developer menu in menu bar).

3X_e_2_e2e61130d15a38840f922061c8961a7fdab7b3da.png

[2022-03-21 09:18:09.338] [info] GraphApp[6de342e9-ac59-4c1e-9a49-351e66e73b36] Decompressing...
[2022-03-21 09:18:29.403] [error] Graph app installation failed Error: Refusing to create a directory outside the output path.
at C:\Users\xxxxx\AppData\Local\Programs\Neo4j Desktop\resources\app.asar\node_modules\decompress\index.js:30:12
at runMicrotasks ()
at processTicksAndRejections (internal/process/task_queues.js:93:5)
at async Promise.all (index 5)
at async f.addGraphApp (C:\Users\xxxxx\AppData\Local\Programs\Neo4j Desktop\resources\app.asar\dist\main.prod.js:1:75461)
at async C:\Users\xxxxx\AppData\Local\Programs\Neo4j Desktop\resources\app.asar\dist\main.prod.js:1:46370
[2022-03-21 09:18:32.267] [info] Online check request: https://dist.neo4j.org/neo4j-desktop/win/latest.yml
[2022-03-21 09:18:32.844] [info] Online check response: 200 version: 1.4.14

1 ACCEPTED SOLUTION

mbandor
Graph Voyager

I believe the Graph Data Science add-ins are not considered Graph Apps but rather plug-ins. If you open the Desktop, find the database of interest, click on the 3 ellipsis (options) dots. On the right you'll see a plug-ins tab. You can install GDS from there.

View solution in original post

2 REPLIES 2

mbandor
Graph Voyager

I believe the Graph Data Science add-ins are not considered Graph Apps but rather plug-ins. If you open the Desktop, find the database of interest, click on the 3 ellipsis (options) dots. On the right you'll see a plug-ins tab. You can install GDS from there.

tom_chiu
Node Link

Thank you so much for your reply. I tried Neo4j Desktop 1.4.13 ( and 1.4.14) and 1.3.4. In 1.3.4, it is true that the plug-in tab will appear which clicking the 3 ellipsis dots, then one can use the tab to install GDS. In 1.4.13 (and 1.4.14), one should click on the name of the database of interest in order to bring up the plug-in tab. Clicking on the 3 ellipsis dots brings up the followings. You are absolutely right that GDS should be a plug-in. Again, thank you very much for your hints.