cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to compile: class file has wrong version 55.0, should be 52.0

wbpaley
Node

Have I missed something or installed incorrectly? I've put Neo4j Community Edition 4.2.2 (tried again with earlier version 4.0.11 and got the same) into IntelliJ IDEA as a library (pointed a new library at the lib dir) and when I try to compile I get this:

Error:(7, 26) java: cannot access org.neo4j.dbms.api.DatabaseManagementService
bad class file: /C:/code/Java/didi/third-party-jars/Neo4j/neo4j-community-4.2.2/lib/neo4j-graphdb-api-4.2.2.jar!/org/neo4j/dbms/api/DatabaseManagementService.class
class file has wrong version 55.0, should be 52.0
Please remove or make sure it appears in the correct subdirectory of the classpath.

1 ACCEPTED SOLUTION

Per How to check Java version used to compile a class | dev cases

Java 8 is version 52.0 and Java 11 is version 55.0

View solution in original post

3 REPLIES 3

dana_canzano
Neo4j
Neo4j

What version of java are you compiling with ??

Per How to check Java version used to compile a class | dev cases

Java 8 is version 52.0 and Java 11 is version 55.0

Yes, using the right SDK sometimes helps... Thanks!