cancel
Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Pause, resolving how to handle anonymous content

Transient Problem:Database not up to the requested version

Fano
Node Link

Hello,
I faced a transient-like problem sometimes, and the same script works well in the next time at most time. It confused me a lot. Any suggestions will be appreciated.

  • neo4j version,
    community3.5.9

  • what kind of API / driver do you use
    driver 1.7.5

  • a sample of the data you want to import

  • which plugins / extensions / procedures do you use

    1. </>apoc.periodic.iterate</> for read,
    2. cypher script also related to write operation in </>apoc.cypher.doIt </> contains </>merge</> and </>set</>.
  • the error.log
    </>
    Caused by: org.neo4j.driver.v1.exceptions.TransientException: Database not up to the requested version: 106451. Latest database version is 106449
    at org.neo4j.driver.internal.util.Futures.blockingGet(Futures.java:123) ~[neo4j-java-driver-1.7.5.jar:1.7.5-d56154a7e96ff71615b894ee9a15d08c370691e6]
    at org.neo4j.driver.internal.NetworkSession.beginTransaction(NetworkSession.java:459) ~[neo4j-java-driver-1.7.5.jar:1.7.5-d56154a7e96ff71615b894ee9a15d08c370691e6]
    at org.neo4j.driver.internal.NetworkSession.beginTransaction(NetworkSession.java:179) ~[neo4j-java-driver-1.7.5.jar:1.7.5-d56154a7e96ff71615b894ee9a15d08c370691e6]
    at org.neo4j.driver.internal.NetworkSession.beginTransaction(NetworkSession.java:173) ~[neo4j-java-driver-1.7.5.jar:1.7.5-d56154a7e96ff71615b894ee9a15d08c370691e6]
    </>

7 REPLIES 7

Cobra
Ninja
Ninja

Hello @Fano

The error says Database not up to the requested version: 106451. Latest database version is 106449 so I think there is a version problem between the driver and the database version. Could you update the database and driver to the latest version?

Regards,
Cobra

Thanks, it cost a lot to change the server version. I can change the version of driver. What version of java driver do you suggest? I can not find the information about the fitted version of driver for related neo4j server.

Cobra
Ninja
Ninja

Which driver language do you use?

I used the driver written in Java.

Cobra
Ninja
Ninja

Yeah complicated...

According to this site, the versions you are using shoud work. I encourage you to upgrade as the builds are meant to fix or improve things, so maybe that's because of that.

Thanks, you meant there are maybe some problems in current version I used. And you suggested I upgrade the java driver to 4.X?

Cobra
Ninja
Ninja

Yes, but if you use the driver version 4.x you must also use the Neo4j database version 4.x.