cancel
Showing results for 
Search instead for 
Did you mean: 

Spring Boot. Neo.ClientError.Security.AuthenticationRateLimit: The client has provided incorrect authentication details too many times in a row

Hi, i used neo4j in my Spring Boot project on an old laptop. I installed Neo4j via a docker-compose file. Everything was fine, everything was working and running. I took another laptop, cloned my project from the old laptop, and via docker-compose installed neo4j on the new laptop. Everything is set up well, but when I enter my username and password in the browser, I get the error Neo.ClientError.Security.AuthenticationRateLimit. Please tell me what could be wrong and how to restore access to neo4j?
Neo4j Browser version: 4.2.5.
The code of my docker-compose file:

  db:
    image: 'neo4j:latest'
    hostname: neo4j
    container_name: db
    ports:
      - "7474:7474"
      - "7687:7687"
    environment:
      - NEO4J_apoc_import_file_enabled=true
      - NEO4J_dbms_shell_enabled=true
    volumes:
      - ./neo4j/plugins:/plugins

Logs when running the docker-compose file:

Directories in use:
  home:         /var/lib/neo4j
  config:       /var/lib/neo4j/conf
  logs:         /logs
  plugins:      /plugins
  import:       /var/lib/neo4j/import
  data:         /var/lib/neo4j/data
  certificates: /var/lib/neo4j/certificates
  run:          /var/lib/neo4j/run
Starting Neo4j.
2021-04-12 11:58:22.113+0000 WARN  Unrecognized setting. No declared setting with name: apoc.import.file.enabled
2021-04-12 11:58:22.117+0000 WARN  Unrecognized setting. No declared setting with name: dbms.shell.enabled
2021-04-12 11:58:22.135+0000 INFO  Starting...
2021-04-12 11:58:27.052+0000 INFO  ======== Neo4j 4.2.5 ========
2021-04-12 11:58:30.147+0000 INFO  Initializing system graph model for component 'security-users' with version -1 and status UNINITIALIZED
2021-04-12 11:58:30.157+0000 INFO  Setting up initial user from defaults: neo4j
2021-04-12 11:58:30.159+0000 INFO  Creating new user 'neo4j' (passwordChangeRequired=true, suspended=false)
2021-04-12 11:58:30.171+0000 INFO  Setting version for 'security-users' to 2
2021-04-12 11:58:30.175+0000 INFO  After initialization of system graph model component 'security-users' have version 2 and status CURRENT
2021-04-12 11:58:30.185+0000 INFO  Performing postInitialization step for component 'security-users' with version 2 and status CURRENT
2021-04-12 11:58:30.549+0000 INFO  Bolt enabled on 0.0.0.0:7687.
2021-04-12 11:58:32.021+0000 INFO  Remote interface available at http://localhost:7474/
2021-04-12 11:58:32.024+0000 INFO  Started.
2021-04-12 12:00:35.023+0000 WARN  The client has provided incorrect authentication details too many times in a row.
0 REPLIES 0