cancel
Showing results for 
Search instead for 
Did you mean: 

Seed Validation Failure

D_K
Node

Migrated data from 4.4.12 to 5.2.0 in a standalone instance, working fine there. Made a backup (tried both offline/online) and now trying to restore it to a cluster of 3 nodes deployed in K8s (helm chart 5.2.0).

Successfully did "neo4j-admin database restore" and "neo4j-admin database check", but after "CREATE DATABASE neo4j OPTIONS {existingData: ‘use’, existingDataSeedInstance: ‘853affdd-abea-4bc0-b7e6-993b4a358ae1’}" the database has problems syncing the data to 2 other nodes.

2022-11-29 22:21:45.039+0000 INFO [c.n.c.s.RemoteSeedValidator] [neo4j/ee0424bb] Response was validated with outcome FAILURE [ StoreContext: StoreValidationContext{transactionId=TransactionId[transactionId=1, checksum=-559063315, commitTimestamp=0]}, Response: TxDataResponse{serverStoreId=StoreId{creationTime=1655804451928, random=-3781483737358411588, storageEngineName='record', formatName='standard', majorVersion=1, minorVersion=1}, serverLastCommittedTxId=641175, serverLastCommittedTxChecksum=-1306307004, clientLastCommittedTxChecksum=N/A}, From: neo4j-11-0-internals.neo4j-11.svc.cluster.local:6000, Validator: StoreInSyncValidationStrategy ]
2022-11-29 22:21:45.040+0000 INFO [c.n.c.s.SeedValidationLifecycle] [neo4j/ee0424bb] The seed validation found current store incompatible. Deleting current store before continuing.
...
2022-11-30 08:30:02.332+0000 INFO [c.n.c.c.s.CoreSnapshotService] [neo4j/ee0424bb] Waiting for another raft group member to publish a core state snapshot

What can be the problem? It's not clear from the logs. Tries to check "SeedValidationLifecycle" implementation but couldn't find it in the github repo.

2 REPLIES 2

D_K
Node

Designated Seeding (from one node) works fine in v4.4 with a cluster of 3 servers deployed via Helm.
URI seeding (uploading to all nodes) works fine in v5.2.

So there is certainly a problem with Designated Seeding in 5.2. Please can someone confirm it if you have the same issue, thx.

Hi @D_K ,

We are experiencing the same issue and we got to know that it will be fixed on version 5.4.

On the other hand we can not make also to run with a URI seeding (on the file URI level), because firstly it is missing that you have to add into configuration the URLConnectionSeedProvider but also because it is going into some other locations.

Have you tried from s3 or from file?

Thanks!

Nodes 2022
Nodes
NODES 2022, Neo4j Online Education Summit

All the sessions of the conference are now available online