Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Phase 2: migrate recent content

"Unknown scheme 'https' "


I'm running a docker container which relies on the neo4j:4.3.2-community image. I have a web interface set up which is supposed to connect to the neo4j instance. I've followed the instructions to set  up SSL over HTTPS (adding a certificate and the requisite config lines enabling https connection) but when I enter `https://the.ip.address:7473` as the URI, I get an error that says "Unknown scheme 'https' ". Is there a reason this should be throwing an error? What do I have to change to fix it? This also occurs if I use 'http.' Bolt does not throw the same error, but I need the traffic to be encrypted so I need to use https.


I think you need to share more of your neo4j config and how you set up SSL?

Which instructions did you follow?

If the same error happens with http, it's unrelated to your SSL setup and you should test first with a plain neo4j docker image if you can access http.

The most common issue for regular installation is that the server only listens on the local address and not external ips so there are configs for listen-address (change from localhost) and advertised address (change to the hostname) that would need to be changed.

Thanks for the reply! My SSL setup isn't complete as I'm going through some hoops to get my hands on the private key I need. However, my situation is a little odd. I'm using the `awspx` docker image from beatro0t, which provides a web-based frontend. I'm running it on an AWS EC2 because docker doesn't work locally. As such I don't know how to test with a "plain" neo4j image, because I have to have the rest of the configurations set up for encrypted traffic via SSL before anyone will approve a firewall rule regarding it. This one uses an APOC jar ( and I've passed my configs in as docker environment variables. I am unable to access http with this method either, though. It returns an almost identical error: "Unknown scheme 'http'." I've tried switching the advertised address to the hostname but that did not change anything. Listen-address is configured as, but that seems appropriate since the frontend is communicating with the neo4j server which is run from the same docker image. Admittedly I'm not a networking expert, a docker expert, or a neo4j expert so I'm not sure if my presumptions are accurate. Should the listen address be changed from