cancel
Showing results for 
Search instead for 
Did you mean: 

Pipeline null error when trying to use Graphware

nickhall122
Node Clone

I'm using David Allen's article here to get the NLP plugin through graphware
up and running locally. https://medium.com/neo4j/using-nlp-in-neo4j-ac40bc92196f

Failed to invoke procedure ga.nlp.annotate: Caused by: java.lang.RuntimeException: No pipeline null

Error message

Showing that I do have a pipeline

Plugins and DB version

Config file does include the following

dbms.unmanaged_extension_classes=com.graphaware.server=/graphaware
com.graphaware.runtime.enabled=true
com.graphaware.module.NLP.1=com.graphaware.nlp.module.NLPBootstrapper
dbms.security.procedures.whitelist=ga.nlp.*

I've seen a lot of people in the community have some heap space issues, but I've changed the query to just try and run with 1 tweet with no luck. I changed the default assumption to a tweet to be that it is English and that didn't work. Could definitely be a beginner issue where I'm not routed to the pipeline correctly.

I definitely do have a pipeline and got a success response when I applied the default pipeline.
CALL ga.nlp.processor.pipeline.default("customStopWords")

Thanks for any help!

1 ACCEPTED SOLUTION

Estelle
Ninja
Ninja

Can you try setting the pipeline in the annotate procedure like this:

MATCH (t:Tweet {language: "en"})
CALL ga.nlp.annotate({
     text: t.text, 
     id: id(t), 
     pipeline : "customStopWords"
}) YIELD result
MERGE (t)-[:HAS_ANNOTATED_TEXT]->(result)
RETURN count(result)

Even if I would also have expected it to use the default pipeline if set.

View solution in original post

2 REPLIES 2

Estelle
Ninja
Ninja

Can you try setting the pipeline in the annotate procedure like this:

MATCH (t:Tweet {language: "en"})
CALL ga.nlp.annotate({
     text: t.text, 
     id: id(t), 
     pipeline : "customStopWords"
}) YIELD result
MERGE (t)-[:HAS_ANNOTATED_TEXT]->(result)
RETURN count(result)

Even if I would also have expected it to use the default pipeline if set.

This worked. Thanks!!
So evidently the setting of a default pipeline isn't working.

Nodes 2022
Nodes
NODES 2022, Neo4j Online Education Summit

On November 16 and 17 for 24 hours across all timezones, you’ll learn about best practices for beginners and experts alike.