cancel
Showing results for 
Search instead for 
Did you mean: 

Neo4j slave node doesn't sync data from master node in HA cluster

yunzhoun
Node Link

Hi everyone,

I need some help here.

I'm trying to put a new node into my existing HA cluster and sync the data from the master node (there is no data on my new node).
The ip of my new node is 9.54.145.185

I set following configuration:
ha.initial_hosts=9.22.14.21:20029,9.22.58.228:20029,9.22.34.221:20029,100.117.134.244:20021,9.41.160.169:20029,10.160.142.32:20021 (copied from one node in cluster)
ha.host.data=:20031
ha.server_id=200 (a new one)
ha.host.coordination=:20029
ha.host.data=:20031

Other configuration is the same with the configuration of nodes in cluster.

After I start the new server, I can see following in the log:

2020-10-22 03:13:49.645+0000 INFO  ======== Neo4j 3.2.3 ========
2020-10-22 03:13:49.669+0000 INFO  Starting...
2020-10-22 03:13:50.469+0000 INFO  Write transactions to database disabled
2020-10-22 03:13:50.559+0000 WARN  Causal Clustering metrics was enabled but the graph database is not in Causal Clustering mode.
2020-10-22 03:13:50.851+0000 INFO  Bolt enabled on 0.0.0.0:20025.
2020-10-22 03:13:50.874+0000 INFO  Initiating metrics...
2020-10-22 03:13:52.032+0000 INFO  Attempting to join cluster of [9.22.14.21:20029, 9.22.58.228:20029, 9.22.34.221:20029, 100.117.134.244:20021, 9.41.160.169:20029, 10.160.142.32:20021]
2020-10-22 03:13:52.138+0000 INFO  Joined cluster: Name:neo4j.ha Nodes:{97=cluster://9.22.14.21:20029, 98=cluster://9.22.58.228:20029, 99=cluster://100.117.134.244:20021, 5=cluster://9.25.15.143:10084, 102=cluster://9.22.34.221:20029, 103=cluster://10.160.142.32:20021, 200=cluster://9.54.145.185:20029, 106=cluster://9.22.34.221:20041, 107=cluster://9.41.160.169:20041, 108=cluster://100.117.131.126:20041} Roles:{coordinator=97}
2020-10-22 03:13:52.140+0000 INFO  Sending metrics to Graphite server at 100.107.161.69:2003
2020-10-22 03:13:52.144+0000 INFO  Instance 200 (this server)  entered the cluster
2020-10-22 03:14:19.281+0000 INFO  Instance 108  has failed
2020-10-22 03:14:19.282+0000 INFO  Instance 5  has failed
2020-10-22 03:17:52.339+0000 INFO  Started.
2020-10-22 03:17:53.060+0000 INFO  Mounted REST API at: /db/manage
2020-10-22 03:17:53.137+0000 INFO  Server thread metrics has been registered successfully
2020-10-22 03:17:53.832+0000 INFO  Remote interface available at http://localhost:20027/

It seems this node has successfully joined the cluster, but it never get data from the existing cluster. I also tried to add the ip of this node in the list of ha.initial_host, still doesn't work.

I'm using the enterprise version 3.2.3.

Can someone help me figure this out?

0 REPLIES 0
Nodes 2022
Nodes
NODES 2022, Neo4j Online Education Summit

On November 16 and 17 for 24 hours across all timezones, you’ll learn about best practices for beginners and experts alike.