cancel
Showing results for 
Search instead for 
Did you mean: 

Neo4j remote interface does not start on 7473 port

amit_vora
Node

I am trying to setup HTTPS connector on Neo4J Community version 4.1.8. I have set below environment variables. But, when the server starts, it always creates a remote interface on http://localhost:7474.

Config Variables:
NEO4J_dbms_default__listen__address=0.0.0.0
NEO4J_dbms_connector_default__listen__address=0.0.0.0

NEO4J_dbms_connector_bolt_enabled=true
NEO4J_dbms_connector_bolt_listen__address=0.0.0.0:7687

NEO4J_dbms_connector_http_enabled=false
NEO4J_dbms_connector_https_enabled=true
NEO4J_dbms_connector_https_listen__address=0.0.0.0:7473
NEO4J_dbms_connector_https_address=0.0.0.0:7473

3 REPLIES 3

If you use the docker image it should do it out of the box.

And then just expose the ports. There should be no extra settings necessary.

amit_vora
Node

Thanks Michael.
Yes we are using Docker image but the remote interface does not work with 7473 port.

Logs:
2021-04-13 17:31:16.951+0000 INFO Bolt enabled on 0.0.0.0:7687.
2021-04-13 17:31:20.762+0000 INFO Remote interface available at http://localhost:7474/
2021-04-13 17:31:20.815+0000 INFO Started.

You have to enable SSL via the docker environment options config and also provide certificates.