cancel
Showing results for 
Search instead for 
Did you mean: 

Neo4j ports are not listening

gpgupta7891
Node Link

hi all,

I have build an ubuntu server and the URL https://neo4j_ip:7473 was working fine. We did couple of reboots of this server and stop/start the neo4j service to test the backups but the url is not working now.

I have run the command: sudo netstat -ltnp

here are the results:

ctive Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.53:53 0.0.0.0:* LISTEN 745/systemd-resolve
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 917/sshd
tcp6 0 0 :::22 :::* LISTEN 917/sshd

Another command i ran: url localhost:7473

results:

curl: (7) Failed to connect to localhost port 7473: Connection refused

I am running ubuntu server 18.04.

I think the ubuntu server have stopped listening on the neo4j ports. Can someone please let me know what should i do to fix it.

3 REPLIES 3

kaan
Node

Does port 7474 work? By default, 7474 (HTTP) is enabled, while 7473 (HTTPS) is not.

Another thing to verify – check "neo4j.conf" and make sure this line is active:

dbms.default_listen_address=0.0.0.0

 

gpgupta7891
Node Link

Hi Kaan,

Thank you for your response.

Accessing it on 7474 also gives the same error:

This site can’t be reached

neo4i ip address refused to connect.

Also,

$ curl localhost:7474
curl: (7) Failed to connect to localhost port 7474: Connection refused

dbms.default_listen_address=0.0.0.0
It was active but 0.0.0.0 was not there. so i added it now but still no luck.

kaan
Node

If you start the server like this:

% ./bin/neo4j console

Do you see any output lines like this?

2022-06-14 00:04:32.554+0000 INFO  Remote interface available at http://localhost:7474/

Or maybe there's an error instead? 

Nodes 2022
Nodes
NODES 2022, Neo4j Online Education Summit

On November 16 and 17 for 24 hours across all timezones, you’ll learn about best practices for beginners and experts alike.