cancel
Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site maintenance this Wednesday, February 1. Disruptions expected as we migrate the forums.

Neo4j migration from 2.3.7 to 4.x

thuojb
Node

I am currently trying to upgrade my neo4j from 2.3.7 to 4.x so that I can use GDS and a few other libraries. According to Long upgrade path 2.1.x -> 3.5 the supported upgrade path is Looks like you can go from: 2.1.4 -> 2.1.latest then 2.1.8 -> 2.3.12 then 2.3.12 -> 3.3.9 then 3.3.9 -> 3.5.5

I have successfully upgraded to 2.3.12 but no luck proceeding thereafter.

Seems I should install th 3.3.9, use the neo4j-admin to import the database, then migrate the configurations using the config tool, uncomment dbms.allow_upgrade=true/dbms.allow_upgrade=true then start the db.

However while importing the database, it seems to have already created an empty db while installing and I'm having to delete this so I can import the db (not sure if this is how it's done) Then on starting the server, the database loaded on the browser is actually empty

Anyone who can help?

4 REPLIES 4

glilienfield
Ninja
Ninja

Do you have any plug-in installed? Try removing them during upload and add back in after upgrade. I kinda remember have this problem when upgrading an older version and thus resolved it.

thuojb
Node

Hi glilienfield
No, I do not have any plugins. Rather the plugins folder if empty.
Is it possible you share the steps you followed during your upgrade?

thuojb
Node

sudo service neo4j status
● neo4j.service - Neo4j Graph Database
Loaded: loaded (/lib/systemd/system/neo4j.service; disabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Mon 2022-01-31 05:13:47 EAT; 421ms ago
Process: 82859 ExecStart=/usr/share/neo4j/bin/neo4j console (code=exited, status=1/FAILURE)
Main PID: 82859 (code=exited, status=1/FAILURE)

This is the error message I'm getting now

Exploring the error message further, it is because sudo service neo4j status
NotCleanlyShutDownException: The database is not cleanly shutdown. The database needs recovery, in order to recover the database, please run the old version of the database on this store.

I however did sudo service neo4j stop on root