cancel
Showing results for 
Search instead for 
Did you mean: 

neo4j-import doesn't work with long line

tard_gabriel
Ninja
Ninja

Hi community

This post is mostly intended for devellopers
I was using the neo4j-admin import tool and came across this error

Weird input data, no newline character in the whole buffer 4194304, not supported a.t.m

As I understood it, neo4j-import cannot support having a too long line or record for a node or relationship in a csv
It's espcacially happeing when you have to use field:string[] as the type for one or more of your fields

So your actual line is longer because you might have a lot of data in a single field as a list of values or array property in neo4j.

It kind of sucks because when you deal with massive data it's not unsual I guess to have aggregation of values in a node as a prortery and the neo4-admin import tool is suppose to be THE tool for massive data import.

I hope this can fix
Thanks

Side question: I was wondering how long a list property value in Neo4j can be?

 

 

2 REPLIES 2

There is no limit in neo4j and it should not be limited in the neo4j-admin import tool,

Looks like a bug can you please create an GH issue on 

https://github.com/neo4j/neo4j

sanna_aizad
Node Link

I was getting the same error. The error didn't seem right because it was a csv file and there were plenty of newlines.  It did have records for nodes and relationships but not long lines. I deleted my data and generated it again, then imported it. Worked fine this time.

Nodes 2022
Nodes
NODES 2022, Neo4j Online Education Summit

On November 16 and 17 for 24 hours across all timezones, you’ll learn about best practices for beginners and experts alike.