Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site maintenance this Wednesday, February 1. Disruptions expected as we migrate the forums.

NEO4J-ETL Import error with null pointer exception

Hi everyone, I'm trying to import data from a MySQL local database version 8.0.21 to Neo4j using the neo4j etl tool version 1.5.1 on the neo4j desktop version 4.2.5.

I get this error when I try to import data using direct import or batch mode.

When I run the command in the logs section on the terminal I get the error : - Illegal command (ParseOptionMissingException: Required option 'RDBMS user' is missing)

Here are my logs:
[2021-06-09 16:10:10.065] [info] Executing 'C:\Users\ADMIN.Neo4jDesktop\distributions\java\zulu11.41.23-ca-jdk11.0.8\bin\java.exe, -cp, C:\Users\ADMIN.Neo4jDesktop\graphApps_global\neo4j-etl-ui-4\dist\neo4j-etl.jar,, write, C:\Users\ADMIN\AppData\Local\Temp/import-tool-options.json, eyJtdWx0aWxpbmUtZmllbGRzIjoidHJ1ZSJ9, false'
[2021-06-09 16:10:10.078] [info] Executing 'C:\Users\ADMIN.Neo4jDesktop\distributions\java\zulu11.41.23-ca-jdk11.0.8\bin\java.exe, -cp, C:\Users\ADMIN.Neo4jDesktop\graphApps_global\neo4j-etl-ui-4\dist\neo4j-etl.jar, org.neo4j.etl.NeoIntegrationCli, export, --mapping-file, C:\Users\ADMIN\AppData\Local\Temp/mysql_infomobyafrodb_infomobyafrodb_mapping.json, --rdbms:password, , --rdbms:user, root, --rdbms:url, jdbc:mysql://localhost:3306/infomobyafrodb?autoReconnect=true&useSSL=false&useCursorFetch=true&allowPublicKeyRetrieval=true, --options-file, C:\Users\ADMIN\AppData\Local\Temp/import-tool-options.json, --using, cypher:fromSQL, --unwind-batch-size, 1000, --tx-batch-size, 10000, --neo4j:database-name, smartdata, --neo4j:url, bolt://localhost:7687, --neo4j:user, neo4j, --neo4j:password, 1234dev'
[2021-06-09 16:10:10.452] [info] Process [3064] exit with code '0', signal 'null'
[2021-06-09 16:10:10.843] [info] Process [23464] exit with code '4294967295', signal 'null'

Any help would be appreciated. Thanks!



I am facing the same error.
Did you find a solution for this?

Any help would be appreciated. Thankyou!

Node Link

Empty password to MySql can cause this. Set password to your MySql and try again.

If you run into any issues use the below settings: