cancel
Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Phase 2: migrate recent content

Neo4j error: Project failed to create: Error: EISDIR: illegal operation on a directory, symlink

I've recently installed Neo4j Desktop on Windows 10, and I'm new to the application. When I'm trying to create a project, I get the following error:

Project failed to create: Error: Unable to create or link project: Error: EISDIR: illegal operation on a directory, symlink 'G:\Users\lenovo.Neo4JDesktop\projects\project-28207a01-0348-49e9-b784-06daf8b175cb' -> 'G:\Users\lenovo.Neo4JDesktop\relate-data\projects\project-d6f91a1f-baf6-437f-923c-7341884d2334'

Here is the image of the error:

I have 2 drives on my laptop: The main SSD where Windows is installed, and another external HDD (G:). I tried installing Neo4j on both drives, no luck. However, when I install on the C Drive, the symlink error changes from

'G:\Users\lenovo...' -> 'G:\Users\lenovo...'

to

'C:\Users\anasb...' -> 'G:\Users\lenovo...'

I reinstalled Neo4j several times, changed the location of the data path, still no luck. Is it because I'm running out of space on the C drive? Also, I notice that when I open Neo4j, it shows no projects found. However, when I installed it on another machine, there are some sample databases, e.g. Movie Database that show up.

I tried Googling for the error, but it seems no one has ever gotten such an error.

Where have I gone wrong? Would appreciate a solution ASAP.

3 REPLIES 3

JRood
Node

I am having the same issue with v1.4.14. Already tried earlier versions to no avail.

Hello there, did you solve this? I have the same issue, also on Windows 10.
Did the same: uninstalled etc, and that didn't help.
The version I have installed is 1.4.15.

Thanks in advance for letting us know how you solved this

EDIT: I solved this by installing the previous version of neo4j, which is 1.3.4

Couple of steps

  1. Upgrade your java to the current version
  2. reinstall Neo4J desktop
  3. use single user to make a fresh install if previously used everyone
  4. under settings, switch the database to a drive under your username i.e. C:\Users\mark\Neo4J
  5. Now create a new project and it will eliminate your problem