Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Phase 2: migrate recent content

Neo4j desktop upgrade and Graph Data Science Library

Node Link

I am using the Neo4j Desktop Enterprise Edition version 4.2.1. Here I run into a problem with the Graph Data Science Libary. When trying to execute the Dijkstra Algorithm I got the message:
ERROR: There is no procedure with the name gds.shortestPath.dijkstra.write.estimate registered for this database instance. Please ensure you've spelled the procedure name correctly and that the procedure is properly deployed.
My version of GDS is 1.2. I want to update, but could not find out how. So I tried to first upgrade Neo4J, but this also failed. I cannot even upgrade sequentially from 4.2.1. to 4.2.2. I am pretty new to programming. Could anyone help please?
Thanks, Elisabeth



Hi @ekaske

How about this?

Dump your Graph (4.2.1) with Neo4j Desktop.

Then create another database with 4.4.4 from the dump and you can install the latest GDS.

Sorry, see this only now, because I was busy with other tasks for a few months.
Thanks, but nope. It did not work. The DMBS created from dump was empty. Somewhere I found that I should write "Create Database" in Browser. But this replied "Database 'neo4j' is unavailable."

Node Link

Thanks again. It seems that my Desktop Enterprise version 1.4.14 does not have the full functions. You helped me last time to create a dump using the terminal. But different from your screenshot, the dump is not shown in Desktop, and there is also no way to create a database from dump. I have tried an update of Neo4j from 4.2.1 to 4.3.5. The version is shown in the sidebar, but I cannot create databases in this version. The upgrade process was stalled, and after 10 hours, I force stoped it, perhaps it is incomplete. But the same happened with sequential upgrade to 4.2.2.
I have written to Neo4j whether I should get a paid version. The GDS manual has a section telling me to get a license key for GDS. Perhaps this would work better.
The versioning policy is pretty much a killer for a novice like me.

Node Link

Some progress finally. I installed the latest version on my laptop and restored the database from dump using Terminal and "neo4j-admin load". Have to check whether it is sound, but superficially, it looks okay. Thanks again, Elisabeth