Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site maintenance this Wednesday, February 1. Disruptions expected as we migrate the forums.

Neo4j Desktop does not show any Apps

I haven't used Neo4j Desktop for a few months. When I started it up today, I could start a database, but none of the basic apps (e.g., browser and bloom) appear in the expected locations. How do I get those apps to appear in Desktop again? Are there graph app URLs I can use to manually install browser and bloom?


@rweverwijk Thanks a lot! After removing graphApps.json, the 4 default apps were installed.
On windows, I found this file in C:\Users\{user}\.Neo4jDesktop\persist

View solution in original post



Hi @alfred.sawatzky ,

It looks like you have the latest 1.4.13 . Do you happen to recall the previous version that was working for you? It's possible that this was caused by a migration during upgrade.

As a first step, you could try to remove the graphApps folder, which should trigger a re-install of just the apps. You'll find graphApps under the installation directory for your platform. Check here for some locations: FAQ · neo4j-devtools/neo4j-desktop Wiki · GitHub

You may have to attempt a re-install of Neo4j Desktop following this guide Re-installation of Desktop - Neo4j Desktop

Sorry for the trouble! Hope this helps.


Graph Buddy

Same for me, all graph apps are lost since update to 1.4.13.
graphApps folder in .Neo4jDesktop was empty, deleting didn't help, in Appdata/Roaming there is no such folder.

De-Installing and Re-Installing of Neo4jDesktop (without cleaning files) didn't help.

It's annoying that such an small update already had stolen some hours of my time. The guide for re-installation with dumps would cost another few hours - no way to go.

Please provide a proper version that fixes this. Or a link to download an older version that will work or some other quick workaround.



I ran into the same issue.

I've found a way to get a working Neo4j Desktop again on mac.

  1. Close the Neo4j Desktop app
  2. Move (or remove if you are brave) the graphApps directory like Adreas already mentioned
  3. Move the graphApps.json
  4. Start the Neo4j Desktop

For me these where the paths:

/Users/rvanweverwijk/Library/Application Support/Neo4j Desktop/Application/graphApps
/Users/rvanweverwijk/Library/Application Support/Neo4j Desktop/Application/persist/graphApps.json

After these steps the 4 default neo4j apps are automatically installed:

  • Neo4j Browser
  • Neo4j Bloom
  • Graph Apps Gallery
  • Neo4j ETL Tool

I'm also able to install the apps from the gallery.


@rweverwijk Thanks a lot! After removing graphApps.json, the 4 default apps were installed.
On windows, I found this file in C:\Users\{user}\.Neo4jDesktop\persist

Great that you found a workaround. Could you provide your Neo4j Desktop logs so that I can try to figure out why it happened in the first place? The logs can give me a hint since I'm not able to replicate it myself.

@linuslundahl I'll attach the logs here, added .txt to be able to upload. Not sure if they cover the initial problem as it was a few days ago. Will you also need the old graphApps.json?

log.old.log.txt (1023.9 KB)
log.log.txt (689.6 KB)

If you still have the old graphApps.json file, it would be interesting to see what's in it.

graphApps.json-OLD.txt (17.2 KB)
see attached

Thanks. This worked for me on Windows.

Worked like a charm! Thank you! I found it on my mac on /Library/Application Support/Neo4j Desktop/Application/persist/graphApps.json - deleting that and restarting Desktop solved it.


graphApps.txt (28.8 KB)

Also included mine if it helps to find the common ground there. I see I already removed Neuler from that list before backup.


Found the issue and have a fix ready, will push out a patch release in the coming days. Thank you for supplying the files, it helped with debugging.


Desktop 1.4.14 has just been released and fixes the missing graph apps list issues faced by people in this thread.